[typo] db:create gives "Unknown database"

Michael Hasenstein ruby-forum-incoming at andreas-s.net
Thu Jun 19 09:57:09 EDT 2008


Arun Gupta wrote:

> AIU the main point of db:create is to create the database. Since Rails
> 2.0, I've never use mysqladmin command to create the database and
> always used db:create. I'm still confused why I need to explicitly
> create the database using mysqladmin.
> -Arun


Hi Arun,

No one here believes you? Well I do... had the same error. I found 
several URLs of the same sort, like 
http://justbarebones.blogspot.com/2008/05/rails-202-restful-authentication-and.html 
and this very recent bug report: 
http://rails.lighthouseapp.com/projects/8994/tickets/63-bug-rake-db-create-and-observers
However, I ended up giving up on rails and created my database manually. 
It IS a bug in rails, maybe triggered by one of the plugins, who knows. 
Since it only shows up at db creation time I thought it not worth 
investigating further.


To all those doubters here, first, db:create IS supposed to create the 
database. When I run it and the (empty!) schema exists it complains 
about this fact. When the schema doesn't exist I get the same error as 
Arun. It's just another bug in rails.

Michael
-- 
Posted via http://www.ruby-forum.com/.


More information about the Typo-list mailing list