[typo] Problems with upgrade

Anton J Aylward aja at si.on.ca
Tue Jul 29 10:42:44 EDT 2008


Upgrading Typo with the instructions at
http://typosphere.org/wiki/typo/Upgrade_Typo_with_Typo_installer
and a ~/gems repository fails.

Some stuff  can deal with but this one defeats me.

This is the error I get

.....
Checking database
  Database exists, preparing for upgrade
  expanding apache13.conf.example template
  expanding apache20.conf.example template
  expanding lighttpd.conf.example template
  Migrating Typo's database to newest release
/home/antonaylward/gems/gems/typo-5.1.2/bin/typo:59:in `migrate': 
Migration failed (RailsInstaller::InstallFailed)
         from 
/home/antonaylward/gems/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:689:in 
`in_directory'
         from /home/antonaylward/gems/gems/typo-5.1.2/bin/typo:57:in 
`migrate'
         from 
/home/antonaylward/gems/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:217:in 
`install_sequence'
         from 
/home/antonaylward/gems/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:192:in 
`install'
         from 
/home/antonaylward/gems/gems/rails-app-installer-0.2.0/lib/rails-installer/commands.rb:95:in 
`command'
         from 
/home/antonaylward/gems/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:646:in 
`execute_command'
         from /home/antonaylward/gems/gems/typo-5.1.2/bin/typo:93
         from /home/antonaylward/gems/bin/typo:19:in `load'
         from /home/antonaylward/gems/bin/typo:19



A manual "rake db:migrate" completes OK.

-- 
There are two ways to slide easily through life: to believe
everything or to doubt everything; both ways save us from
thinking.           -- Alfred Korzybski


More information about the Typo-list mailing list