[typo] Cannot log in after 5.04b update

R. N. Dominick rdominick at gmail.com
Sun Jul 6 22:43:44 EDT 2008


When the 5.04b announcement went out, I did an svn up to update my Typo
installation. The main blog renders fine (http://blog.peekle.net/) but I
can't log in to the admin. I put in my login and password, but when I hit
"Login" the login page just refreshes. If I look in the log, I can see a new
session being created and the admin/dashboard action being redirected to
accounts/login; after I put in my credentials, I can see it processing them,
and they all pass through just fine, a cookie gets set in my browser with
the correct session ID, and Typo redirects to admin -- which promptly
redirects back to accounts/login again.

I did the usual thing after an svn up breaks Typo, which is to wait a few
days and up it again. No dice there.

I notice the authenticity_token stuff is new, and I gather that's a new
Rails feature, but I've no idea what it's all about.

Anyone ever seen this, or have any advice on where to look? Thanks for any
help anyone might be able to give.

Log file, edited for security reasons, below.

Processing DashboardController#index (for 74.138.200.63 at 2008-07-07
02:25:29) [GET]
  Session ID: 3eb8649....
  Parameters: {"action"=>"index", "controller"=>"admin/dashboard"}
generate({:controller=>"accounts/login", :action=>"index"},
{:controller=>"accounts/login", :action=>"index"}, {:controller=>true,
:action=>false}) reached the default route
Redirected to http://blog.peekle.net/accounts/login
Filter chain halted as
[#<ActionController::Filters::ClassMethods::SymbolFilter:0x2a9887cb08
@filter=:login_required>] rendered_or_redirected.
Completed in 0.00156 (640 reqs/sec) | DB: 0.00000 (0%) | 302 Found [
http://blog.peekle.net/admin/]


Processing AccountsController#login (for 74.138.200.63 at 2008-07-07
02:25:29) [GET]
  Session ID: 3eb8649....
  Parameters: {"action"=>"login", "controller"=>"accounts"}
Rendering template within layouts/accounts
Rendering accounts/login
Completed in 0.00239 (418 reqs/sec) | Rendering: 0.00146 (61%) | DB: 0.00000
(0%) | 200 OK [http://blog.peekle.net/accounts/login]


Processing AccountsController#login (for 74.138.200.63 at 2008-07-07
02:25:30) [POST]
  Session ID: 3eb8649....
  Parameters: {"user_login"=>"xxxxxxxx",
"authenticity_token"=>"60113de....", "action"=>"login",
"controller"=>"accounts", "user_password"=>"xxxxxxxx", "login"=>"Login »"}
Redirected to http://blog.peekle.net/admin/
Completed in 0.00142 (702 reqs/sec) | DB: 0.00000 (0%) | 302 Found [
http://blog.peekle.net/accounts/login]


Processing DashboardController#index (for 74.138.200.63 at 2008-07-07
02:25:30) [GET]
  Session ID: 3eb8649....
  Parameters: {"action"=>"index", "controller"=>"admin/dashboard"}
generate({:controller=>"accounts/login", :action=>"index"},
{:controller=>"accounts/login", :action=>"index"}, {:controller=>true,
:action=>false}) reached the default route
Redirected to http://blog.peekle.net/accounts/login
Filter chain halted as
[#<ActionController::Filters::ClassMethods::SymbolFilter:0x2a9887cb08
@filter=:login_required>] rendered_or_redirected.
Completed in 0.00187 (533 reqs/sec) | DB: 0.00000 (0%) | 302 Found [
http://blog.peekle.net/admin/]
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://rubyforge.org/pipermail/typo-list/attachments/20080706/ab7baab1/attachment.html>


More information about the Typo-list mailing list