[typo] Problems with upgrade

Anton J Aylward aja at si.on.ca
Sat Aug 9 09:35:47 EDT 2008

de Villamil Frédéric said the following on 09/08/08 04:11 AM:
> I remember running into this when I tried to build 5.0.3 gem. Can you  
> run ./script/console RAILS_ENV=your_current_environment and launch
> Blog.find(:all)

I''m sure you didn't mean that!

$ ./script/console RAILS_ENV=development
Loading RAILS_ENV=development environment (Rails 2.0.2)
`read':Errno::ENOENT: No such file or directory - 


[ralphie]$ RAILS_ENV=development ./script/console
Loading development environment (Rails 2.0.2)
 >> Blog.find(:all)
=> []

[ralphie]$ RAILS_ENV=production ./script/console
Loading production environment (Rails 2.0.2)
 >> Blog.find(:all)
=> []

> If it returns nothing, then something went wrong during the install  
> process since you MUST have the default blog created at install.

OK, so (a) why would that have happened?  I didn't record it but the 
install didn't report any errors.  (b) What to do about it.

> Are you sure you're running Rails 2.0.2 btw ?


> I'll be absent til sunday evening so don't expect any reply before  
> monday

its not life critical.

It is an error to imagine that evolution signifies a constant tendency 
to increased perfection. That process undoubtedly involves a constant 
remodelling of the organism in adaptation to new conditions; but it 
depends on the nature of those conditions whether the directions of the 
modifications effected shall be upward or downward.
     Thomas H. Huxley

More information about the Typo-list mailing list