[typo] Problems with upgrade

de Villamil Frédéric frederic at de-villamil.com
Sat Aug 9 04:11:21 EDT 2008


Le 8 août 08 à 15:07, Anton J Aylward a écrit :

> After much fluffing around and quite possibly by accident I got the  
> version of Typo-5.1.2 running on my laptop.  heartened by this I  
> returned to my Dreamhost account and tried once again to set up a  
> clean/new instance.
>
> No luck.
> The "typo install" went well.  I'd set up GEN_HOME and GEM_PATH and  
> PATH and checked carefully that the gems being used were the ones I  
> thought.
> All looked fine until I tried running it.  Neither the real nor the  
> admin interfaces worked - I got a 500 on each.
>
> The logs reported ...
>
> Processing DashboardController#index (for 99.225.104.173 at  
> 2008-08-07 19:50:00) [GET]
>  Session ID: 93269476e54e65f3421f49ddacabab13
>  Parameters: {"action"=>"index", "controller"=>"admin/dashboard"}
>
>
> NoMethodError (undefined method `lang' for nil:NilClass):
>    /app/controllers/application.rb:35:in `load_lang'
>    /vendor/rails/actionpack/lib/action_controller/filters.rb:469:in  
> `send!'
>    /vendor/rails/actionpack/lib/action_controller/filters.rb:469:in  
> `call'
>    /vendor/rails/actionpack/lib/action_controller/filters.rb:441:in  
> `run'
>
>
> Well hey, that's different from before when it was complaining about  
> current_user being undefined this time.
>
> So what's up here?  Is this another undocuemnted dependency?
>

Hello,

I remember running into this when I tried to build 5.0.3 gem. Can you  
run ./script/console RAILS_ENV=your_current_environment and launch
Blog.find(:all)

If it returns nothing, then something went wrong during the install  
process since you MUST have the default blog created at install.
Are you sure you're running Rails 2.0.2 btw ?

I'll be absent til sunday evening so don't expect any reply before  
monday

Cheers,
Frédéric
-- 
Frédéric de Villamil
frederic at de-villamil.com                        tel: +33 (0)6 62 19 1337
http://fredericdevillamil.com             Typo : http://typosphere.org



More information about the Typo-list mailing list