[typo] Problems with upgrade

Anton J Aylward aja at si.on.ca
Fri Aug 8 09:07:11 EDT 2008

After much fluffing around and quite possibly by accident I got the 
version of Typo-5.1.2 running on my laptop.  heartened by this I 
returned to my Dreamhost account and tried once again to set up a 
clean/new instance.

No luck.
The "typo install" went well.  I'd set up GEN_HOME and GEM_PATH and PATH 
and checked carefully that the gems being used were the ones I thought.
All looked fine until I tried running it.  Neither the real nor the 
admin interfaces worked - I got a 500 on each.

The logs reported ...

Processing DashboardController#index (for at 2008-08-07 
19:50:00) [GET]
   Session ID: 93269476e54e65f3421f49ddacabab13
   Parameters: {"action"=>"index", "controller"=>"admin/dashboard"}

NoMethodError (undefined method `lang' for nil:NilClass):
     /app/controllers/application.rb:35:in `load_lang'
     /vendor/rails/actionpack/lib/action_controller/filters.rb:469:in `call'
     /vendor/rails/actionpack/lib/action_controller/filters.rb:441:in `run'

Well hey, that's different from before when it was complaining about 
current_user being undefined this time.

So what's up here?  Is this another undocuemnted dependency?

	"Context is everything"

More information about the Typo-list mailing list