[typo] Problems with upgrade

Esteban Manchado velázquez ruby-forum-incoming at andreas-s.net
Thu Aug 7 16:38:02 EDT 2008


Esteban Manchado velázquez wrote:
> Anton Aylward wrote:
>> I also get
>> 
>> 
>> 
>> ActionView::TemplateError (Couldn't find template file for
>> /sidebars/sidebar/_content in ["~/typo5/themes/typographic/views",
>> "/~typo5/app/views"]) on
>> line #27 of themes/typographic/layouts/default.html.erb:
>> 24:       <%= render :partial => 'shared/search' %>
>> 25:
>> 26:       <!-- sidebar components -->
>> 27:       <%= render_sidebars %>
>> 28:     </div>
>> 29:
>> 30:     <div id="content">
> 
> I had the same problem, and found the solution (at least it worked for 
> me). The problem is that some leftovers in the sidebars table are left, 
> probably in the upgrade migrations.
> 
> What you have to do is open the console (in production environment or 
> whatever other environment you're using for your blog) and remove the 
> sidebars that have undefined "type" (= nil). This line should do:
> 
> Sidebar.find(:all, :order => 'active_position ASC').find_all {|s| 
> s.type.nil?}.each {|s| s.destroy}
> 
> (Yeah, the line could be simpler, I just copy-pasted the line I just 
> used, while I was experimenting)

Gah! I just realised that this will delete the HTML blocks (e.g. with 
links) that you may have, so you have to remake those. You should have a 
backup copy of the database, even if you execute that thing first and 
then read this message, so it shouldn't be a problem...
-- 
Posted via http://www.ruby-forum.com/.


More information about the Typo-list mailing list