[typo] Problems with upgrade

de Villamil Frédéric frederic at de-villamil.com
Thu Aug 7 11:24:04 EDT 2008


Le 7 août 08 à 16:42, Anton J Aylward a écrit :

> de Villamil Frédéric said the following on 06/08/08 03:51 PM:
>> [Big Snip of relevant material - review previous messages if you  
>> need it ]
>> This is not a Typo but rails issue: to use a Rails application,  
>> you  need a database driver, ie ruby mysql driver. That's the  
>> reason why  you needed so much dependencies. In an ideal world,  
>> your distro would  embed a package named ruby-mysql with the proper  
>> driver, or anything  else.
>
> Help me here.
>
> Typo is built on and thus dependent on Rails
> Rails is the part that needs the database drives, not Typo itself.
>
> Is that correct?
>
> So, if I were to use gem to remove the typo gem, update the various  
> gems that make up rails, probably activerecord in particular, doing  
> whatever compiles are necessary, and then used gem to install the  
> typo gem, it wouldn't be a problem, because the database driver is  
> in Rails not in Typo.
>
> So I do that and this is what I get:
>
>
> [root at laptop ~]# gem update
> Updating installed gems
> Nothing to update
> [root at laptop ~]# gem list | egrep "rails|action|active|typo"
> actionmailer (2.1.0, 2.0.2, 2.0.1, 1.3.3, 1.3.2, 1.3.1, 1.2.5,  
> 1.2.1, 1.0.1)
> actionpack (2.1.0, 2.0.2, 2.0.1, 1.13.3, 1.13.2, 1.13.1, 1.12.5,  
> 1.12.1, 1.9.1)
> actionwebservice (1.2.6, 1.2.3, 1.2.1, 1.1.6, 1.1.2, 0.8.1)
> activerecord (2.1.0, 2.0.2, 2.0.1, 1.15.3, 1.15.1, 1.14.4, 1.14.2,  
> 1.11.1)
> activeresource (2.1.0, 2.0.2, 2.0.1)
> activesupport (2.1.0, 2.0.2, 2.0.1, 1.4.2, 1.4.0, 1.3.1, 1.1.1)
> rails (2.1.0, 2.0.2, 2.0.1, 1.2.3, 1.2.2, 1.2.1, 1.1.6, 1.1.2)
> rails_product (0.6, 0.5)
> transaction-simple (1.4.0)
> [root at lpatop ~]# gem install typo
> Building native extensions.  This could take a while...
> ERROR:  Error installing typo:
>        ERROR: Failed to build gem native extension.
>
> /usr/bin/ruby extconf.rb install typo
> checking for fdatasync() in -lrt... yes
> checking for sqlite3.h... no
> *** extconf.rb failed ***
> Could not create Makefile due to some reason, probably lack of
> necessary libraries and/or headers.  Check the mkmf.log file for more
> details.  You may need configuration options.
>
>
>
> The mkmf.log just repeats that and gives a list of compile options.
>
>
>> The problem is Rails gem has its own dependencies system which   
>> differs from RPM and you won't register Typo MySQL gem with rpm  
>> and  the contrary.
>
> It would be nice if dynamic linking was used under Linux.
> Never the less, it appears that Typo is trying to compile database  
> drivers of its own.
>
>
>> I've actually tried to reduce the number of dependencies in the  
>> last  releases, removing some of them as much as I could.
>
> So what dependency is triggering this?
> I have other rails applications on my laptop that use sqlite3 and  
> mysql with the installed rails gems.  Surely that means I have a  
> sqlite and mysql driver that rails can make use of.
>
> Surely dependencies would be one of the things that needs to be  
> documented!
>
>
> Never the less, none of this addresses the problems I've had at  
> Deeamhost and when I've tried installing from the tarz-ball.
> Please see my other mail under this subject heading.
>


libsqlite3-devel or something like this

Regards
Frédéric
-- 
Frédéric de Villamil
frederic at de-villamil.com                        tel: +33 (0)6 62 19 1337
http://fredericdevillamil.com             Typo : http://typosphere.org



More information about the Typo-list mailing list