[typo] Which versions of Ruby work with Typo 5.1.2?

de Villamil Frédéric frederic at de-villamil.com
Wed Aug 6 16:12:22 EDT 2008


Le 5 août 08 à 15:07, Cyril Mougel a écrit :

> On Tue, Aug 5, 2008 at 11:05 AM, Geoffrey Sisson
> <ruby-forum-incoming at andreas-s.net> wrote:
>> Cyril Mougel wrote:
>>
>>> I use a ruby 1.8.6-p230 with Typo 5.1.2 and I haven't any problem.  
>>> All
>>> works
>>
>> Cyril, are you using Rails 2.0.2?
>
> Yes, it's with rails freeze in Typo.
>
>>
>> When I use Ruby 1.8.6-p230 and Rails 2.0.2 and then create a new
>> instance of Typo, the resulting dispatch.cgi crashes immediately upon
>> invocation:
>>
>> $ ./dispatch.cgi
>> *** glibc detected *** ruby: free(): invalid pointer: 0x085510d0 ***
>> ======= Backtrace: =========
>> /lib/i686/cmov/libc.so.6[0xb7d6f4f4]
>> /lib/i686/cmov/libc.so.6(cfree+0x96)[0xb7d716f6]
>> /usr/lib/libruby.so.1.8[0xb7f0dc4c]
>> [snip]
>>
>>
>> I'm running on Debian GNU/Linux 4.0r4 (etch), FWIW.
>
> I use mongrel and I am a Gentoo.


Hello,

first, sorry for not replying faster, I was in holliday and got  
internet access only tonight. Trying to answer the pile of mails  
that's waiting for me.

I'm currently using Ruby Enterprise Edition (the name really sucks),  
which is developped by the guys from mod_rails. It fixes the ruby  
security vuln while not breaking everything, which is just what I  
needed.

Cheers,
Frédéric

-- 
Frédéric de Villamil
frederic at de-villamil.com                        tel: +33 (0)6 62 19 1337
http://fredericdevillamil.com             Typo : http://typosphere.org



More information about the Typo-list mailing list