[typo] Problems with upgrade

de Villamil Frédéric frederic at de-villamil.com
Wed Aug 6 15:51:29 EDT 2008

Le 5 août 08 à 14:03, Anton J Aylward a écrit :

> Matijs van Zuijlen said the following on 04/08/08 08:55 PM:
>> Hi Anton,
> Hi, and thanks.  No, realy, I'm grateful someone finally replied.  I  
> was
> getting frustrated.  (Still am actually!)
> This was my 4th or fifth post about problems with this version of  
> Typo.
> I'd tried upgrading my site first - MISTAKE! - and have a number of
> posts about that.  Perhaps you'd care to look back over them and  
> comment
> on that content as the experience was a bit different from this  
> attempt
> to install Typo on my laptop
>> Anton Aylward wrote:
>>> So, in an effort to compare the upgrade with a virgin install, I'm
>>> trying to install typo on my laptop.
>> What OS are you running on your laptop. I'm guessing Linux? Which
>> distribution?
> Mandriva 2008.0
>>> I start with
>>> $ sudo gem install typo
>>> and I get
>>> [...]
>>> Could not create Makefile due to some reason, probably lack of
>>> necessary libraries and/or headers.  Check the mkmf.log file for  
>>> more
>>> details.  You may need configuration options.
>> What are those details in mkmf.log?
> See later
>>> Oh!
>>> Well I do have /usr/lib/mysqlclient ...
>>> # rpm -q -f /usr/lib/libmysqlclient.so
>>> libmysql15-5.0.45-8.2mdv2008.0
>>> Now it happens that is sripped.  I don't know why.
>> Ah, an rpm based distro. Probably you need to install the -dev  
>> package
>> for libmysql as well.
> I really don't like this.
> Why should I have to install an application development package just  
> to
> install Typo?  Will I have to install a compiler and possibly YACC/LEX
> as well.
> Please guys, this is a bit of a heavy load.
> So I load up gcc etc and it turns out that the error in the log file  
> is
> conftest.c: In function ‘t’:
> conftest.c:3: error: ‘mysql_query’ undeclared (first use in this  
> function)
> Is this set of dependencies (on the compiler etc) declared anywhere?
> Why do I have to go though this if I only want to use Typo with  
> sqlite3
>>> So I gave up o that and tried installing from the .tgz
>>> I unpacked ok, and then
>>> [...]
>>> `gem_original_require': no such file to load -- rails-installer  
>>> (LoadError)
>>>        from
>>> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in  
>>> `require'
>>>        from ./typo-5.1.2/bin/typo:4
>>> Hmm.  So I try
>>> [anton at laptop Ruby]$ find /usr/lib/ruby /home/anton \
>>>                          -name 'rails-installer*' -print
>>> which returns nothing.
>> The typo gem requires 'rails-app-installer', I'm guessing you need to
>> install that gem.
> Is that dependency declared anywhere?
> Oh, right, let me guess, if I'd installed with the GEM it would have
> dragged that dependency in.
> My "other" blog is Wordpress & I didn't have this problem upgrading  
> that.
> Originally preferred Typo to Wordpress, now I'm having my doubts.
> I'm really disappointed in this "upgrade".  When I started using Typo
> two years ago (26/08/06 08:54 PM) I had none of these problems,  
> neither
> on my laptop nor on Dreamhost (once they got Ruby 1.8.4 up).  It was  
> the
> slickness and ease of installation & configuration that impressed me
> back them.
> PostScript:
> I just installed 'libmysql-devel' using urpmi, the normal and
> recommended method, and 'gem install typo' still fails.
> I seriously think you need to reconsider what it takes for an ordinary
> non-development user to install Typo.
>> Regards,
>> Matijs.


first, sorry for not replying faster, I was in holliday and got  
internet access only tonight. Trying to answer the pile of mails  
that's waiting for me.

This is not a Typo but rails issue: to use a Rails application, you  
need a database driver, ie ruby mysql driver. That's the reason why  
you needed so much dependencies. In an ideal world, your distro would  
embed a package named ruby-mysql with the proper driver, or anything  
else. The problem is Rails gem has its own dependencies system which  
differs from RPM and you won't register Typo MySQL gem with rpm and  
the contrary.

I've actually tried to reduce the number of dependencies in the last  
releases, removing some of them as much as I could.

Frédéric de Villamil
frederic at de-villamil.com                        tel: +33 (0)6 62 19 1337
http://fredericdevillamil.com             Typo : http://typosphere.org

More information about the Typo-list mailing list