[typo] Which versions of Ruby work with Typo 5.1.2?

Matijs van Zuijlen matijs at matijs.net
Wed Aug 6 10:50:23 EDT 2008


Geoffrey Sisson wrote:
> Does anyone have Typo running with a version of Ruby more recent than
> 1.8.6-p114?

Rails 2.0.2 does not work with Ruby 1.8.7.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484351 for details.
There's a git repository with backported fixes from Rails 2.1 here:
http://git.debian.org/?p=users/terceiro-guest/rails.git;a=shortlog;h=refs/heads/2.0.2-ruby1.8.7-compat

I used that source to recreate some of the gems (I don't really
understand Rails' build system), and now have working 2.0.2 gems with
ruby 1.8.7.

Regards,
Matijs.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: OpenPGP digital signature
URL: <http://rubyforge.org/pipermail/typo-list/attachments/20080806/a3961a6f/attachment.bin>


More information about the Typo-list mailing list