[typo] Problems with upgrade

Anton J Aylward aja at si.on.ca
Tue Aug 5 08:03:20 EDT 2008


Matijs van Zuijlen said the following on 04/08/08 08:55 PM:
> Hi Anton,

Hi, and thanks.  No, realy, I'm grateful someone finally replied.  I was
getting frustrated.  (Still am actually!)

This was my 4th or fifth post about problems with this version of Typo.
I'd tried upgrading my site first - MISTAKE! - and have a number of
posts about that.  Perhaps you'd care to look back over them and comment
on that content as the experience was a bit different from this attempt
to install Typo on my laptop


> Anton Aylward wrote:
>> So, in an effort to compare the upgrade with a virgin install, I'm
>> trying to install typo on my laptop.
> 
> What OS are you running on your laptop. I'm guessing Linux? Which
> distribution?

Mandriva 2008.0

>> I start with
> 
>> $ sudo gem install typo
> 
>> and I get
> 
>> [...]
>> Could not create Makefile due to some reason, probably lack of
>> necessary libraries and/or headers.  Check the mkmf.log file for more
>> details.  You may need configuration options.
> 
> What are those details in mkmf.log?

See later

>> Oh!
>> Well I do have /usr/lib/mysqlclient ...
>> # rpm -q -f /usr/lib/libmysqlclient.so
>> libmysql15-5.0.45-8.2mdv2008.0
>> Now it happens that is sripped.  I don't know why.
> 
> Ah, an rpm based distro. Probably you need to install the -dev package
> for libmysql as well.

I really don't like this.
Why should I have to install an application development package just to
install Typo?  Will I have to install a compiler and possibly YACC/LEX
as well.

Please guys, this is a bit of a heavy load.

So I load up gcc etc and it turns out that the error in the log file is


conftest.c: In function ‘t’:
conftest.c:3: error: ‘mysql_query’ undeclared (first use in this function)



Is this set of dependencies (on the compiler etc) declared anywhere?
Why do I have to go though this if I only want to use Typo with sqlite3



>> So I gave up o that and tried installing from the .tgz
>> I unpacked ok, and then
> 
>> [...]
>> `gem_original_require': no such file to load -- rails-installer (LoadError)
>>         from
>> /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in `require'
>>         from ./typo-5.1.2/bin/typo:4
> 
> 
>> Hmm.  So I try
> 
>> [anton at laptop Ruby]$ find /usr/lib/ruby /home/anton \
>>                           -name 'rails-installer*' -print
> 
>> which returns nothing.
> 
> The typo gem requires 'rails-app-installer', I'm guessing you need to
> install that gem.

Is that dependency declared anywhere?

Oh, right, let me guess, if I'd installed with the GEM it would have
dragged that dependency in.

HA-BLOODY-HA-HA

My "other" blog is Wordpress & I didn't have this problem upgrading that.

Originally preferred Typo to Wordpress, now I'm having my doubts.
I'm really disappointed in this "upgrade".  When I started using Typo
two years ago (26/08/06 08:54 PM) I had none of these problems, neither
on my laptop nor on Dreamhost (once they got Ruby 1.8.4 up).  It was the
slickness and ease of installation & configuration that impressed me
back them.



PostScript:

I just installed 'libmysql-devel' using urpmi, the normal and
recommended method, and 'gem install typo' still fails.

I seriously think you need to reconsider what it takes for an ordinary
non-development user to install Typo.








> Regards,
> Matijs.
-- 
You can either take action, or you can hang back and hope for a miracle.
Miracles are great, but they are so unpredictable.
    --Peter F. Drucker


More information about the Typo-list mailing list