[typo] Which versions of Ruby work with Typo 5.1.2?

Cyril Mougel cyril.mougel at gmail.com
Tue Aug 5 02:01:08 EDT 2008


On Tue, Aug 5, 2008 at 2:25 AM, Geoffrey Sisson
<ruby-forum-incoming at andreas-s.net> wrote:
> Does anyone have Typo running with a version of Ruby more recent than
> 1.8.6-p114?  This version has known vulnerabilities, as reported here:
>
> http://www.ruby-lang.org/en/news/2008/06/20/arbitrary-code-execution-vulnerabilities/
>
> I've tried with all the most recent versions of Ruby 1.8 -- 1.8.7-p22,
> 1.8.6-p230 and 1.8.5-p231 -- but these all seem to cause Typo to crash
> in one place or another (the crash with 1.8.7-p22 is documented as Issue
> 1243 [1]).  I'm using Rails 2.0.2 and mysql gem 2.7.
>
> I'd really like to use Typo, but am reluctant to do so if it can only be
> run insecurely.

I use a ruby 1.8.6-p230 with Typo 5.1.2 and I haven't any problem. All works

-- 
Cyril Mougel
http://blog.shingara.fr


More information about the Typo-list mailing list