[typo] Themes breaking clean install

Kristopher A Tillery katillery at gmail.com
Tue Sep 18 01:31:19 EDT 2007


Hello,

I am new to Typo and just performed a clean install.  Everything works fine
when using the Azure theme, but when I switch to another theme (I have tried
Hemingway and Scribbish) I get an error when attempting to load my blog.  No
problem activating the theme in the control panel, the error only occurs
when I leave the admin area.  The error varies by theme; I am wondering if
maybe themes are broken or if I am doing something wrong: any help would be
appreciated.  Apologies in advance for my lack of RoR knowledge: sorry I
can't figure this one out myself.  Thanks!

Error generated by Scribbish:
ActionController::RoutingError in Articles#index

Showing *themes/scribbish/views/articles/_article.rhtml* where line
*#26*raised:

xml_url failed to generate from {:type=>"article", :format=>"rss",
:controller=>"xml", :id=>"3", :action=>"feed"}, expected:
{:type=>"sitemap", :format=>"googlesitemap", :controller=>"xml",
:action=>"feed"}, diff: {:type=>"sitemap", :format=>"googlesitemap",
:id=>"3"}

Extracted source (around line *#26*):

23:       <%= trackbacks_link(article) if article.allow_pings? %>
24:       <%= comments_link(article)   if article.allow_comments? %>
25:       <a href="<%= article.permalink_url %>" rel="bookmark">permalink</a>
26:       <a href="<%= xml_url :action=>'feed', :type=>'article',
:format => 'rss',  :id => article %>">rss</a>
27:       <a href="<%= xml_url :action=>'feed', :type=>'article',
:format => 'atom', :id => article %>">atom</a>
28:     </li>
29:   </ul>

Trace of template inclusion: /themes/scribbish/views/articles/index.rhtml

RAILS_ROOT: /usr/local/typo/config/..
Application Trace <http://localhost:4826/#> | Framework
Trace<http://localhost:4826/#>| Full
Trace <http://localhost:4826/#>

#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/routing.rb:1273:in
`raise_named_route_error'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/routing.rb:1245:in
`generate'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/url_rewriter.rb:104:in
`rewrite_path'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/url_rewriter.rb:69:in
`rewrite'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/base.rb:522:in
`url_for'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/url_helper.rb:27:in
`send'
#{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/helpers/url_helper.rb:27:in
`url_for'
#{RAILS_ROOT}/app/helpers/application_helper.rb:15:in `url_for'
(eval):19:in `xml_url'
#{RAILS_ROOT}/themes/scribbish/views/articles/_article.rhtml:26:in
`_run_rhtml_47themes47scribbish47views47articles47_article46rhtml'
#{RAILS_ROOT}/themes/scribbish/views/articles/index.rhtml:1:in
`_run_rhtml_47themes47scribbish47views47articles47index46rhtml'
/usr/local/bin/mongrel_rails:16:in `load'
/usr/local/bin/mongrel_rails:16



Error generated by Hemingway:
RuntimeError in Articles#index

Showing *themes/hemingway/views/articles/index.rhtml* where line *#21*raised:

Unimplemented

Extracted source (around line *#21*):

18: 		<% end -%>
19: 		
20: 		<div class="clear"></div>
21: 		<% unless @pages.item_count <= config[:limit_article_display] %>
22: 		  <p id="pagination">Older posts: <%= pagination_links @pages,
:params => { :action => @controller.action_name } %></p>
23: 		<% end -%>
24: 		

RAILS_ROOT: /usr/local/typo/config/..
Application Trace <http://localhost:4826/#> | Framework
Trace<http://localhost:4826/#>| Full
Trace <http://localhost:4826/#>

#{RAILS_ROOT}/app/helpers/application_helper.rb:91:in `config'
#{RAILS_ROOT}/themes/hemingway/views/articles/index.rhtml:21:in
`_run_rhtml_47themes47hemingway47views47articles47index46rhtml'
/usr/local/bin/mongrel_rails:16:in `load'
/usr/local/bin/mongrel_rails:16
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20070918/d423b07e/attachment-0001.html 


More information about the Typo-list mailing list