[typo] Unable to run trunk (1349)

Kevin Ballard kevin at sb.org
Tue Jan 23 13:26:08 EST 2007


On Jan 21, 2007, at 2:38 PM, Lars Roland wrote:

> On 1/21/07, Kevin Ballard <kevin at sb.org> wrote:
>>
>> It looks like you're missing, um, rubygems itself.
>
> I installed typo using the Debian instructions (used to be in typo
> track if i remember correctly) with rails and ruby stuff from the
> Debian packages. It just seamed unlikely that my otherwise quite
> stable typo installation would break over night on such a simple thing
> as gems so I just ignored it

According to the source, boot.rb (a file generated by rails) loads  
rubygems if it cannot find rails in the vendor/rails dir. Perhaps you  
don't have typo frozen into vendor/rails?

UPDATE: Oh boy, it appears at least one of the plugins we have  
installed requires 'rubygems' blindly. So yeah, you need rubygems  
installed even if rails is frozen into vendor/rails. That said, you  
should still have it frozen.

>> And yeah, you should have rails 1.2. There's an svn:externals to  
>> check out
>> rails 1.2 into the vendor folder, but if you're using a tool like  
>> svk that's
>> not going to work for you. You really should freeze Rails 1.2.1  
>> into the
>> vendor folder if it's not there.
>>
>
> I removed the Debian rails package and install rubygems, so now there
> is only the rails version in vendor (1.2.1) on my system (running on
> ruby 1.8.5). WEBrick now starts, but typo fails, when browsing it, the
> error is:
>
> [snip]
>
> Any ideas ?.

Did you install the dependencies for rails? That stack isn't  
particularly illuminating, but it looks like it tried to resolve an  
unknown constant reference and ended up trying to qualify an  
anonymous module. I really don't know what that implies..

Here's what I recommend: go back and follow the Debian instructions  
again. This time make sure rails is frozen into vendor/rails (if  
you're using typo 4.0.3 [the latest stable release of typo] I believe  
it wants rails 1.1.6, if you're using svn trunk you want rails  
1.2.1). Also make sure you have rubygems installed, but don't bother  
installing rails via rubygems (as it's already frozen into vendor/ 
rails).

Tell me if you get another error.

-- 
Kevin Ballard
http://kevin.sb.org
kevin at sb.org
http://www.tildesoft.com


-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20070123/41151cea/attachment.html 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2432 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/typo-list/attachments/20070123/41151cea/attachment.bin 


More information about the Typo-list mailing list