[typo] <typo:lightbox/> macro issues

John Gedeon orangej2 at gmail.com
Thu Feb 1 18:43:43 EST 2007


Hello,

    Typo and ruby noob here. I just installed typo 4.0.3 on my site, the
host has rails 1.1.6 and ruby 1.8.5 installed, everything went smooth and
configured fine. I wanted to test out the lightbox macro with a photo on my
site. I added the tag

   <typo:lightbox src="http://example.org/originals/1.jpg" thumbsrc="
http://example.org/thumbs/originals.jpg"/>

   however, at first it just rendered visible until I turned off the Textile
filter. Once that was off the post text only showed up but the tag was as is
in the html source and didn't show on the page. I looked through the logs
and found the following at about the time I had tried to load the page.

Processing ContentController#show (for 199.106.103.254 at 2007-02-01
16:29:39) [
GET]
  Session ID: 8f7464f1dac3fd6620b17391a1ba5183
  Parameters: {"action"=>"show", "id"=>"1", "controller"=>"admin/content"}
Rendering  within layouts/administration
Rendering admin/content/show
Filter macropost failed: undefined method `empty?' for nil:NilClass
Completed in 0.08970 (11 reqs/sec) | Rendering: 0.08559 (95%) | DB: 0.00166(1%)
 | 200 OK [http://test.gedeons.com/admin/content/show/1]


Processing ArticlesController#index (for 199.106.103.254 at 2007-02-01
16:29:57)
 [GET]
  Parameters: {"action"=>"index", "controller"=>"articles"}
Rendering  within ../../themes/azure/layouts/default
Rendering articles/index
Filter macropost failed: undefined method `empty?' for nil:NilClass
BENCHMARK: layout/content (0.00005)
Start rendering component ({:controller=>SidebarController,
:action=>"display_pl
ugins"}):

not sure what that means, I tried searching the archives and google but
could not find anything. Do I have to turn the macros on or did something go
wrong with my install?

TIA,
John
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20070201/ae39d3d3/attachment-0001.html 


More information about the Typo-list mailing list