[typo] Help Rails 2.0 with typo 4.1.1

John Gedeon orangej2 at gmail.com
Thu Dec 13 12:02:27 EST 2007

Thanks for the follow up. I tried rake rails:freeze:gems VERSION=1.2.6 and
found this result:

Freezing to the gems for Rails 1.2.6
ERROR:  While executing gem ... (Gem::Exception)
    Cannot load gem at [/usr/lib/ruby/gems/1.8/cache/activesupport-1.4.4.gem
gedeonsc at gedeons.com [~/custom_apps/typo-4.1.1-ctpd]#
script/about              ./script/../config/boot.rb:16:in `require': no
such file to load --
script/../config/../vendor/rails/railties/lib/initializer (LoadError)
        from ./script/../config/boot.rb:16
        from script/about:2:in `require'
        from script/about:2

So that seems like it would have worked but maybe my hosts install of
1.2.6is incomplete. Fortunately the downloaded tgz of rails had the
directory I needed. and putting that in vendor/rails of typo fixed the

Thanks again for the quick reply


On 12/13/07, Rick DeNatale <rick.denatale at gmail.com> wrote:
> On 12/13/07, John Gedeon <orangej2 at gmail.com> wrote:
> > I have typo 4.1.1 installed on my host that just upgraded to rails 2.0.1
> .
> > They still have rails 1.2.6 installed but typo is using 2.0.1 and is
> broken
> > with a huge stack trace that I didn't have before, and I have made no
> > changes myself so it must be that. I know I should have frozen the gem
> > before, but now I do not know how to switch it so that typo uses the old
> > rails plugin. I tried adding RAILS_GEM_VERSION = ' 1.2.6' in my
> > environment.rb file but that doesn't help.
> >
> > Please let me know if there is any other useful info I can send. Mostly
> I
> > think I just need to know how to freeze rails to a previous version of
> the
> > plugin which is installed in /usr/lib/ruby/gems along side the latest.
> >
> > Also I can't use rake rails:freeze:edge TAG=rel_1-2-6 because my host
> > doesn't have svn installed.
> I think you can use
> rake freeze:gems VERSION=1.2.6
> The freeze:gems task seems to use the VERSION environment variable.
> --
> Rick DeNatale
> My blog on Ruby
> http://talklikeaduck.denhaven2.com/
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20071213/da6f777b/attachment-0001.html 

More information about the Typo-list mailing list