[typo] 4.1 Upgrade problems

Toby Bryans toby-typo at bryans.org
Tue Apr 3 18:28:02 EDT 2007


Don't worry about it - there was a problem with the underlying database
which meant I had to backup, drop and completely restore the whole thing.

Thanks if you did have a look; I'm happily upgraded now!

Best wishes,

-- 
Toby

>
> bryans at cyglon01 ~/www/rails $ typo install
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/
>  Installing typo 4.1
>  Stopping Typo
> !!! PID file /u01/sites/bryans.org/www/rails/toblog.bryans.org/tmp/pid.txt
> does not exist.  Not running?
> mongrel::stop reported an error. Use mongrel_rails mongrel::stop -h to get
> help.
>  Checking for existing Typo install in
> /u01/sites/bryans.org/www/rails/toblog.bryans.org
>  Reading files from /usr/lib/ruby/gems/1.8/gems/typo-4.1
>  copying rails 1.2.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/railties
>  copying activesupport 1.4.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/activesupport
>  copying activerecord 1.15.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/activerecord
>  copying actionpack 1.13.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/actionpack
>  copying actionmailer 1.3.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/actionmailer
>  copying actionwebservice 1.2.0 to
> /u01/sites/bryans.org/www/rails/toblog.bryans.org/vendor/rails/actionwebservice
>  Making scripts executable
>  Checking database
>  Creating initial database
>  Creating PostgreSQL database
> Password:
> createdb: database creation failed: ERROR:  permission denied to create
> database
> Password:
> createdb: database creation failed: ERROR:  permission denied to create
> database
> /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.0/lib/active_record/connection_adapters/abstract_adapter.rb:128:in
> `log': PGError: ERROR:  relation "articles_tags" already exists
> (ActiveRecord::StatementInvalid)
> : CREATE TABLE articles_tags (
>   "article_id" integer DEFAULT NULL,
>   "tag_id" integer DEFAULT NULL
> )       from
> /usr/lib/ruby/gems/1.8/gems/activerecord-1.15.0/lib/active_record/connection_adapters/postgresql_adapter.rb:152:in
> `execute'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/databases.rb:125:in
> `create'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/databases.rb:124:in
> `each'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/databases.rb:124:in
> `create'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:479:in
> `create_initial_database'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:689:in
> `in_directory'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:478:in
> `create_initial_database'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:213:in
> `install_sequence'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:192:in
> `install'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer/commands.rb:95:in
> `command'
>         from
> /usr/lib/ruby/gems/1.8/gems/rails-app-installer-0.2.0/lib/rails-installer.rb:646:in
> `execute_command'
>         from /usr/lib/ruby/gems/1.8/gems/typo-4.1/bin/typo:38
>         from
> /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:in
> `load'
>         from
> /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:in
> `load'
>         from
> /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:343:in
> `new_constants_in'
>         from
> /usr/lib/ruby/gems/1.8/gems/activesupport-1.4.0/lib/active_support/dependencies.rb:489:in
> `load'
>         from /usr/bin/typo:18
>
> So, why is it trying to do a CREATE TABLE? Have I missed something
> somewhere which prevents it from realising that this is an upgrade as
> opposed to an install?
>
> Many thanks for any hints you can give me and if you need any more
> information do let me know!
>
> Best wishes,
>
> --
> Toby
>
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>




More information about the Typo-list mailing list