[typo] non theme images cause rails error

heromuto heromuto at fastmail.jp
Sat Sep 16 17:09:36 EDT 2006


Hello

My typo blog is not showing images from my /files/ folder basicly
anything that is not part of my theme is returning a rails error.

The log files says:

NameError (uninitialized constant FilesController):
    /vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:100:in
    `const_missing'
    /vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:131:in
    `const_missing'
    generated/routing/recognition.rb:525:in `recognize_path'
    /vendor/rails/actionpack/lib/action_controller/routing.rb:511:in
    `recognize!'
    /vendor/rails/railties/lib/dispatcher.rb:38:in `dispatch'
    /vendor/rails/railties/lib/fcgi_handler.rb:150:in `process_request'
    /vendor/rails/railties/lib/fcgi_handler.rb:54:in `process!'
    /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:600:in
    `each_cgi'
    /usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in
    `each_cgi'
    /vendor/rails/railties/lib/fcgi_handler.rb:53:in `process!'
    /vendor/rails/railties/lib/fcgi_handler.rb:23:in `process!'
    /users/home/dalcross_admin/domains/thumbsucker.info/web/public/dispatch.fcgi:24

I have run rake migrate, restarts everything, but to no avail.

Host: Typo
SVN version: 1254:5127M
Database: pgsql


Can anyone direct me further as to how to resolve this problem.

Hermouto
-- 
  heromuto
  heromuto at fastmail.jp

-- 
http://www.fastmail.fm - A no graphics, no pop-ups email service



More information about the Typo-list mailing list