[typo] page_header error

Piers Cawley pdcawley at bofh.org.uk
Fri Nov 24 12:57:14 EST 2006

"Steve Lenti" <stevelenti at 3pop.com> writes:

> One of my posts just all of a sudden started giving me a Rails

Just one post? That was working fine before? And you've made no
changes to either typo or your rails installation?

> Application error when I try to view it through its permalink.  I get
> the following error.
> Processing Base#permalink (for at 2006-11-24 09:13:25) [GET]
>   Parameters: {"month"=>"10", "title"=>"google-sitemaps-with-typo",
> "action"=>"permalink", "controller"=>"articles", "day"=>"13",
> "year"=>"2006"}
> ActionView::TemplateError (private method `select' called for
> 0:Fixnum) on line #6 of themes/razure/layouts/default.rhtml:
> 3: <head>
> 4:   <title><%=h page_title %></title>
> 5:   <script src="/mint/?js" type="text/javascript"></script>
> 6:   <%= page_header %>
> 7:   <%= stylesheet_link_tag "/stylesheets/theme/razure", :media => 'all'  %>
> 8:   <%= stylesheet_link_tag "/stylesheets/theme/local", :media => 'all'  %>
> 9: </head>
> The weird thing is that it has nothing to do with the theme I am
> using.  I have tried three different themes all with the same result.
> It was working fine up until I edited the article then resaved it.

Hmm... I can't seem to replicate this. Can you try running

 $ RAILS_ENV=production ./script/console 

from your rails root directory. Then

 >> a = Article.find(<id of dodgy article>)

You can find out the dodgy article's id by looking at it on the
admin/content page. The article's URL will be /admin/content/show/<id>

Once you've got that, do:

 >> a.whiteboard

And let us know the results. If the answer is 'nil', do

 >> a.html(:all); nil
 >> a.whiteboard

and mail back with *that* result.

Piers Cawley <pdcawley at bofh.org.uk>

More information about the Typo-list mailing list