[typo] page_header error

Steve Lenti stevelenti at 3pop.com
Fri Nov 24 11:18:27 EST 2006


One of my posts just all of a sudden started giving me a Rails
Application error when I try to view it through its permalink.  I get
the following error.

Processing Base#permalink (for 192.168.15.101 at 2006-11-24 09:13:25) [GET]
  Parameters: {"month"=>"10", "title"=>"google-sitemaps-with-typo",
"action"=>"permalink", "controller"=>"articles", "day"=>"13",
"year"=>"2006"}

ActionView::TemplateError (private method `select' called for
0:Fixnum) on line #6 of themes/razure/layouts/default.rhtml:
3: <head>
4:   <title><%=h page_title %></title>
5:   <script src="/mint/?js" type="text/javascript"></script>
6:   <%= page_header %>
7:   <%= stylesheet_link_tag "/stylesheets/theme/razure", :media => 'all'  %>
8:   <%= stylesheet_link_tag "/stylesheets/theme/local", :media => 'all'  %>
9: </head>

The weird thing is that it has nothing to do with the theme I am
using.  I have tried three different themes all with the same result.
It was working fine up until I edited the article then resaved it.

Any suggestions?

-Steve
http://youdummy.net/blog


More information about the Typo-list mailing list