[typo] The rails_1_1 branch

Kevin Kubasik kevin at kubasik.net
Thu Mar 30 07:58:22 EST 2006


Sorry, some of that seems to have been leftover processes, oops....
A proper restart reveils a small issue under 1.1 with the content admin pages:
Processing ContentController#index (for 205.222.248.25 at 2006-03-3007:55:13) [GET]  Session ID: 7e020172db947e7eee8a3e5e635317e3  Parameters: {"action"=>"index", "controller"=>"admin/content"}Rendering admin/content/list within layouts/administrationRendering admin/content/list

NoMethodError (undefined method `controller_name' for nil:NilClass):    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:541:in`callback'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/caching.rb:534:in`after'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:227:in`around_filter'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:388:in`call_filters'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:381:in`call_filters'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:376:in`after_action'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:356:in`perform_action_without_benchmark'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:in`perform_action_without_rescue'    /usr/lib/ruby/1.8/benchmark.rb:293:in `measure'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/benchmarking.rb:69:in`perform_action_without_rescue'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/rescue.rb:82:in`perform_action'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/base.rb:379:in`process_without_filters'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/filters.rb:364:in`process_without_session_management_support'    /usr/lib/ruby/gems/1.8/gems/actionpack-1.12.0/lib/action_controller/session_management.rb:117:in`process'    /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/dispatcher.rb:38:in `dispatch'    /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:150:in`process_request'    /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:54:in `process!'    /usr/lib/ruby/1.8/fcgi.rb:600:in `each_cgi'    /usr/lib/ruby/1.8/fcgi.rb:597:in `each_cgi'    /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:53:in `process!'    /usr/lib/ruby/gems/1.8/gems/rails-1.1.0/lib/fcgi_handler.rb:23:in `process!'    /public/dispatch.fcgi:24



On 3/30/06, Kevin Kubasik <kevin at kubasik.net> wrote:> Update, works with both 1.1 and 1 (I had no real issues when trying> development mode as well)>> Cheers,> Kevin Kubasik>> On 3/30/06, Kevin Kubasik <kevin at kubasik.net> wrote:> > Ok, I can report success on Ubuntu Dapper with rails 1.0 and lighttp,> > I'll be giving 1.1 a try later today.> >> > Cheers,> > Kevin Kubasik> > On 3/30/06, Jon Gretar Borgthorsson <jon.borgthorsson at gmail.com> wrote:> > > Switched yesterday... Works fine under 1.1> > >> > > On 3/30/06, cedric <cedric at feelfree.homelinux.com> wrote:> > > > Hello all,> > > >> > > > This morning I've switched on the rails_1_1 branch for my typo blogs> > > > (production & development)> > > >> > > > After a restart of my apache server, everything just works perfectly!> > > >> > > > Thanks for this great job!> > > >> > > > PS:my installation: Apache 2.0.54 on debian Sarge, rails 1.1 :-), fastcgi> > > > module> > > >> > > > Regards Cédric> > > >> > > > Le Jeudi 30 Mars 2006 07:01, Piers Cawley a écrit:> > > > > Okay, who wants to be on the bleading edge?> > > > >> > > > > If you've been watching the typo trac[1], you'll have seen that we now> > > > > have a rails_1_1 branch. If you've been watching carefully, you'll be> > > > > aware that we think we've ironed out the bugs and it works for both> > > > > Rails 1.1 and 1.0 with the following caveat:> > > > >> > > > > * Under Rails 1.0 it's a wee bit fragile in development mode; if you> > > > >   interrupt a request before it's finished, you'll get a white screen> > > > >   of death> > > > >> > > > > However, from the testing I've managed to give it, it seems to be> > > > > reasonably bulletproof under Rails 1.1 in both development and> > > > > production mode, and under Rails 1.0 in production mode. Since a lot> > > > > of you are using production mode, you probably won't see the 1.0> > > > > problems.> > > > >> > > > > So, before we merge the branch back onto the main line and call it> > > > > done, we'd appreciate bug reports and 'no bug' reports from as many> > > > > people as possible. The magic incantation to run from your typo base> > > > > directory is> > > > >> > > > >   $ svn switch svn://typosphere.org/typo/branches/rails_1_1> > > > >> > > > > If you don't have your typo repository under svn control, you can> > > > > check it out using:> > > > >> > > > >   $ svn co svn://typosphere.org/typo/branches/rails_1_1 <target_directory>> > > > >> > > > > If you're running Typo 2.6.0, you'll need to freeze rails 1.0 in your> > > > > vendor directory; I'm afraid we're unlikely to go back and fix it to> > > > > work with Rails 1.1, but if anyone has a patch.> > > > >> > > > > 1. http://www.typosphere.org/trac/timeline -- a good place to start> > > >> > > > _______________________________________________> > > > Typo-list mailing list> > > > Typo-list at rubyforge.org> > > > http://rubyforge.org/mailman/listinfo/typo-list> > > >> > >> > >> > > --> > > --------------> > > Jon Gretar Borgthorsson> > > http://www.jongretar.net/> > >> > > _______________________________________________> > > Typo-list mailing list> > > Typo-list at rubyforge.org> > > http://rubyforge.org/mailman/listinfo/typo-list> > >> >> >> > --> > Cheers,> > Kevin Kubasik> > http://blog.kubasik.net/> >>>> --> Cheers,> Kevin Kubasik> http://blog.kubasik.net/>

--Cheers,Kevin Kubasikhttp://blog.kubasik.net/


More information about the Typo-list mailing list