[typo] The rails_1_1 branch

cedric cedric at feelfree.homelinux.com
Thu Mar 30 00:22:40 EST 2006


Hello all,

This morning I've switched on the rails_1_1 branch for my typo blogs 
(production & development)

After a restart of my apache server, everything just works perfectly!

Thanks for this great job!

PS:my installation: Apache 2.0.54 on debian Sarge, rails 1.1 :-), fastcgi 
module

Regards Cédric

Le Jeudi 30 Mars 2006 07:01, Piers Cawley a écrit :
> Okay, who wants to be on the bleading edge?
>
> If you've been watching the typo trac[1], you'll have seen that we now
> have a rails_1_1 branch. If you've been watching carefully, you'll be
> aware that we think we've ironed out the bugs and it works for both
> Rails 1.1 and 1.0 with the following caveat:
>
> * Under Rails 1.0 it's a wee bit fragile in development mode; if you
>   interrupt a request before it's finished, you'll get a white screen
>   of death
>
> However, from the testing I've managed to give it, it seems to be
> reasonably bulletproof under Rails 1.1 in both development and
> production mode, and under Rails 1.0 in production mode. Since a lot
> of you are using production mode, you probably won't see the 1.0
> problems.
>
> So, before we merge the branch back onto the main line and call it
> done, we'd appreciate bug reports and 'no bug' reports from as many
> people as possible. The magic incantation to run from your typo base
> directory is
>
>   $ svn switch svn://typosphere.org/typo/branches/rails_1_1
>
> If you don't have your typo repository under svn control, you can
> check it out using:
>
>   $ svn co svn://typosphere.org/typo/branches/rails_1_1 <target_directory>
>
> If you're running Typo 2.6.0, you'll need to freeze rails 1.0 in your
> vendor directory; I'm afraid we're unlikely to go back and fix it to
> work with Rails 1.1, but if anyone has a patch.
>
> 1. http://www.typosphere.org/trac/timeline -- a good place to start



More information about the Typo-list mailing list