[typo] Rails 1.1?

Jon Gretar Borgthorsson jon.borgthorsson at gmail.com
Wed Mar 29 00:01:33 EST 2006


Seeing that many of the bigger hosting companies have upgraded to
version 1.1 after just one day I have to say that any fancy methods of
supporting both 1.0 and 1.1 are unneeded and will only complex typo. I
think the best thing to do is to make the current trunk be the last
version to support 1.0 and make an archive of it available in some
back support page.

I think it is quite obvious that rails 1.0 is not going to be with us for long.


On 3/29/06, Steve Longdo <steve.longdo at gmail.com> wrote:
> I ran afoul of Textdrive also.  The only way to keep running there is to
> roll back to Rails 1.0 by running:
>
> rake freeze_edge REVISION=3303
>
> FYI when you run a "newer" release of Typo (somewhere in the late r800's) it
> consumes enough memory that the Textdrive servers will kill the process
> anyway.  Until memory consumption can be reigned in, no one will be running
> a newer version of Typo on Textdrive's servers.  Something holds on too way
> more memory than it should.  I haven't been able to track it down yet.
>
> Mostly because other than ObjectSpace to see in general how many objects
> there are, I don't know of a way to see how much memory a given object/set
> of objects is taking up.  Would a C extension to call sizeOf be necessary or
> the some other way to findout Object memory size in Ruby?
>
> -Steve
>
>
> On 3/28/06, Nicholas Van Weerdenburg <vanweerd at gmail.com> wrote:
> >
> > Textdrive upgraded today already. No warning, broke my app.
> >
> >
> >
> > On 3/28/06, Gary Shewan <gpsnospam at gmail.com> wrote:
> > >
> > > On 28 Mar 2006, at 15:35, Jon Gretar Borgthorsson wrote:
> > >
> > > > Well... Fixing the "enable_upload_progress" bug so that typo will work
> > > > with rails 1.1 would be a start.
> > > >
> > > >
> > > > -------------
> > > > Jon Gretar Borgthorsson
> > > >
> > > > On 3/28/06, Scott Laird < scott at sigkill.org> wrote:
> > > >> So, it's out.  What do we do?
> > > >>
> > >
> > > Well apart from what Jon mentions, how far away is Typo from being
> > > 1.1 compatible?  I do have a beady eye on it because last time
> > > Dreamhost did the upgrade with no notice.  I'd say the prospect of
> > > hosting companies upgrading is still a few weeks away.  There's time
> > > there to look at what needs to be done.
> > >
> > > Gary
> > > _______________________________________________
> > > Typo-list mailing list
> > > Typo-list at rubyforge.org
> > > http://rubyforge.org/mailman/listinfo/typo-list
> > >
> >
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
> >
> >
>
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
>


--
--------------
Jon Gretar Borgthorsson



More information about the Typo-list mailing list