[typo] How to lock Typo to Rails 1.0?

Sean Mountcastle smountcastle at gmail.com
Tue Mar 28 20:56:44 EST 2006

My hosting provider has upgraded to Rails 1.1 without any warning and
it looks like all of the hosted Typo installs are down :(

I tried adding the following to config/environment.rb at the top of
the file, but by that point the Rails 1.1 libraries have already been
loaded (not sure how as the calling script is dispatch.fcgi):

require 'rubygems'
require_gem 'activesupport', '= 1.3.0'
require_gem 'activerecord', '= 1.13.2'
require_gem 'actionpack', '= 1.11.2'
require_gem 'actionmailer', '= 1.1.5'
require_gem 'actionwebservice', '= 1.0.0'

So, where should I lock-down the gems to the Rails 1.0 versions?


/usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:149:in `activate': can't
activate activesupport (= 1.2.5), already activated
activesupport-1.3.0] (Gem::Exception)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:167:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:166:in `activate'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:37:in
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems.rb:31:in `require_gem'
        from .../typo/public/../config/environment.rb:8
        from .../typo/public/dispatch.fcgi:21:in `require'
        from .../typo/public/dispatch.fcgi:21

More information about the Typo-list mailing list