[typo] more migration problems

Piers Cawley pdcawley at bofh.org.uk
Mon Mar 27 09:18:09 EST 2006


Matt Rose <mattrose at folkwolf.net> writes:

> I tried upgrading my dev environment to 946 from 876 and I get this  
> error when I fire up r946
>
> ActiveRecord::StatementInvalid in Articles#index
>
> Mysql::Error: Table 'typo_dev.blogs' doesn't exist: SELECT * FROM  
> blogs  LIMIT 1
>
> So I thought, "OK, I'll migrate my db by hand"
>
> So I go into my rails dir, and I type rake migrate, and I get this.
>
> mattrose at venice:~/rails/typo$ rake migrate
> (in /home/mattrose/rails/typo)
> rake aborted!
> Mysql::Error: Table 'typo_dev.blogs' doesn't exist: ALTER TABLE blogs  
> ADD settings text
>
> (See full trace by running task with --trace)
>
> I ran the trace, but it just gave me the same glaring error.
>
> My r876 rev didn't have the blogs table.
>
> am I missing a step here, or should the migration include a step that  
> creates that blogs table.

It does. In migration 38.

You've not rolled your own migration 38 have you?

-- 
Piers Cawley <pdcawley at bofh.org.uk>
http://www.bofh.org.uk/


More information about the Typo-list mailing list