[typo] Testing typo...

Scott Laird scott at sigkill.org
Mon Jun 19 21:58:08 EDT 2006


I'll re-run some tests as soon as I can, but things were clean the last time
I checked.


Scott

On 6/19/06, Matt Rose <mattrose at folkwolf.net> wrote:
>
>
> these are actually the results with mysql[1]. the sqlite[2] results
> are similar.
>
> I also tried with postgresql and got similar results.
>
> [1]  I don't have the innodb extension built in, and I only use
> myISAM (and believe me, that causes other problems with rails)
>
> [2] Unit: 140 tests, 410 assertions, 10 failures, 5 errors,
> Functional: 204 tests, 472 assertions, 3 failures, 71 errors
>
> Do all these tests work with a newer version of mysql?
>
> On 19-Jun-06, at 8:05 PM, Scott Laird wrote:
>
> > For some reason, sqlite has a hard time with a lot of Typo's
> > tests.  I haven't had time to figure out why.
> >
> >
> > Scott
> >
> > On 6/19/06, Matt Rose < mattrose at folkwolf.net> wrote:
> > So I've been looking into the built in unit tests in typo, and I
> > figured
> > out how to run them.
> >
> > This is the alarming end result:
> >
> > Unit tests:
> > 140 tests, 414 assertions, 14 failures, 8 errors
> >
> > Functional test:
> >
> > 204 tests, 583 assertions, 20 failures, 39 errors
> >
> > and then this:
> >
> > rake aborted!
> > Test failures
> > /home/mattrose/rails/typo/config/../vendor/rails/railties/lib/tasks/
> > testing.rake:35
> > /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in
> > `execute'
> > /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:232:in
> > `execute'
> > /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:202:in
> > `invoke'
> > /usr/local/lib/ruby/1.8/thread.rb:135:in `synchronize'
> > /usr/local/lib/ruby/gems/1.8/gems/rake- 0.7.0/lib/rake.rb:195:in
> > `invoke'
> > /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in `run'
> > /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.0/lib/rake.rb:1719:in `run'
> > /usr/local/lib/ruby/gems/1.8/gems/rake- 0.7.0/bin/rake:7
> > /usr/local/bin/rake:18
> >
> > So, a whole bunch of unit tests fail on the latest trunk.  I think
> > some of it is db-dependent, as I get a different result using an
> > sqlite database, but I'm at a loss to explain the sheer amount of
> > errors.
> >
> > Does anyone have a platform where all these tests pass?
> >
> > --
> > ----------------------------------------------------------------------
> > --
> > --
> > Matt Rose     mattrose at folkwolf.net    Visit my blog!  http://
> > folkwolf.net
> > He's an uncontrollable pirate gangster with no name. She's an
> > enchanted
> > thirtysomething cab driver with a song in her heart and a spring in
> > her
> > step. They fight crime!
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060619/2058d719/attachment.htm 


More information about the Typo-list mailing list