[typo] The deadly 500...

levi mccallum vemon388 at gmail.com
Fri Jun 16 18:36:44 EDT 2006


Sorry to send so many emails, I am sort of treating this like a chat. But
anyway.
I looked through the latest printed log. And you are right it is getting
stuck on the side bar.

It's having trouble displaying plugins. I am puzzled about this.

Log below:


>    Rendering actionerrorlayoutfalse within ../../themes/lucid/layouts/default
>    Rendering articles/error
>    Start rendering component ({:controller=>"sidebars/sidebar", :action=>"display_plugins"}):
>
>
>    Processing Base#index (for 220.236.132.89 at 2006-06-16 15:31:29) [GET]
>      Parameters: {"action"=>"index", "controller"=>"articles"}
>
>
>    ActionView::TemplateError (uninitialized constant Sidebars::SidebarController) on line #57 of themes/lucid/layouts/default.rhtml:
>    54: <div id="subcol">
>    55:   <div class="bt"><div></div></div>
>    56:   <div id="sc2">
>    57: <%= render_component(:controller => 'sidebars/sidebar', :action => 'display_plugins') %>
>    58: <%= link_to image_tag("powered.gif"),  "http://typo.leetsoft.com/", {:class => "powered" } %>
>    59:   </div>
>    60: </div> <!-- end #subcol -->
>
>        #{RAILS_ROOT}/vendor/rails/activesupport/lib/active_support/dependencies.rb:100:in `const_missing'
>        #{RAILS_ROOT}/vendor/rails/activesupport/lib/active_support/inflector.rb:161:in `module_eval'
>        #{RAILS_ROOT}/vendor/rails/activesupport/lib/active_support/inflector.rb:161:in `module_eval'
>        #{RAILS_ROOT}/vendor/rails/activesupport/lib/active_support/inflector.rb:161:in `constantize'
>        #{RAILS_ROOT}/vendor/rails/activesupport/lib/active_support/core_ext/string/inflections.rb:59:in `constantize'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:143:in `component_class'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:133:in `component_response'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:108:in `render_component_as_string'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:107:in `component_logging_with_unfiltered_options'
>        #{RAILS_ROOT}/lib/rails_patch/components.rb:10:in `component_logging'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:107:in `render_component_as_string'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:44:in `send'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/components.rb:44:in `render_component'
>        #{RAILS_ROOT}/themes/lucid/layouts/default.rhtml:57:in `_run_rhtml__home_46asparagus_humbleadmin_railsblog_themes_lucid_layouts_default'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/base.rb:314:in `send'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/base.rb:314:in `compile_and_render_template'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/base.rb:290:in `render_template'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_view/base.rb:249:in `render_file'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/layout.rb:249:in `render_without_benchmark'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in `render'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in `measure'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in `render'
>        #{RAILS_ROOT}/app/controllers/articles_controller.rb:64:in `rescue_action_in_public'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/rescue.rb:33:in `rescue_action'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/rescue.rb:108:in `perform_action'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/base.rb:381:in `send'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/base.rb:381:in `process_without_filters'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/filters.rb:377:in `process_without_session_management_support'
>        #{RAILS_ROOT}/vendor/rails/actionpack/lib/action_controller/session_management.rb:117:in `process'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/dispatcher.rb:38:in `dispatch'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/fcgi_handler.rb:150:in `process_request'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/fcgi_handler.rb:54:in `process!'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/fcgi_handler.rb:53:in `each_cgi'
>        /usr/lib/ruby/1.8/fcgi.rb:597:in `each'
>        /usr/lib/ruby/1.8/fcgi.rb:597:in `each_cgi'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/fcgi_handler.rb:53:in `process!'
>        #{RAILS_ROOT}/vendor/rails/railties/lib/fcgi_handler.rb:23:in `process!'
>        dispatch.fcgi:24
>
>
>
>
On 6/16/06, levi mccallum <vemon388 at gmail.com> wrote:
>
> Nope, none of them are effecting the page.. I removed them all, and
> nothing changed.
>
>
> On 6/16/06, levi mccallum <vemon388 at gmail.com > wrote:
> >
> > Nope, It's not, I removed it.... I'll try other sidebar items...
> >
> >
> > On 6/16/06, levi mccallum < vemon388 at gmail.com > wrote:
> > >
> > > ? really?
> > >
> > > Wow, I would of never guessed..
> > >
> > >
> > > On 6/16/06, Andrey Nikanorov <nikanorov at gmail.com > wrote:
> > > >
> > > > It seems to be flickr sidebar problem.
> > > >
> > > > On 6/17/06, levi mccallum < vemon388 at gmail.com> wrote:
> > > > > Freak!!! This is getting so annoying....
> > > > >
> > > > > The page works for a while, then when I update my sidebar, it
> > > > doesn't!!!!!
> > > > >
> > > > > I want to break something!
> > > > >
> > > > >
> > > > > ---------- Forwarded message ----------
> > > > >  From: levi mccallum <vemon388 at gmail.com>
> > > > > Date: Jun 16, 2006 9:41 PM
> > > > > Subject: Re: [typo] The deadly 500...
> > > > > To: typo-list at rubyforge.org
> > > > >
> > > > > Lol, Andy your funny.
> > > > >
> > > > > Anyway, What kind of things can I do to stop it?
> > > > >
> > > > >
> > > > > On 6/16/06, Andy Carrel < william.a at carrel.org > wrote:
> > > > > > Followed up to the ticket, but noting it here too. The error is
> > > > coming
> > > > > > from the connect routines in the MySQL adapter. It's appears to
> > > > be
> > > > > > angry about an argument it is receiving to connect with.
> > > > ("Database
> > > > > > adapter mad! Database adapter smash! Rar! *crunch* 500.")
> > > > > >
> > > > > > On 6/16/06, levi mccallum < vemon388 at gmail.com> wrote:
> > > > > > > Ok guys, I was a little vague in my explanation.
> > > > > > >
> > > > > > > I am on dreamhost, running 1055 svn.
> > > > > > >
> > > > > > > It seems that I only get those error messages when I go strait
> > > > to the
> > > > > > > domain, e.g. http://evilmac.org .
> > > > > > > but if I go http://evilmac.org/admin it logs in.
> > > > > > >
> > > > > > > The site seemed to work for a few hours last night, then I get
> > > > the same
> > > > > > > error this morning.
> > > > > > >
> > > > > > >  I am running fastcgi. And I am really stuck in the mud
> > > > here....
> > > > > > >
> > > > > > >
> > > > > > > On 6/16/06, Gary Shewan < gpsnospam at gmail.com > wrote:
> > > > > > > > On 16 Jun 2006, at 14:27, Timothy Freund wrote:
> > > > > > > >
> > > > > > > > > What shows up in ./log/production.log when you hit the
> > > > site and get
> > > > > > > > > the
> > > > > > > > > Application error message?
> > > > > > > >
> > > > > > > > It's included in the Trac ticket:
> > > > > > > >
> > > > > > > > http://www.typosphere.org/trac/ticket/942
> > > > > > > >
> > > > > > > > G
> > > > > > > > _______________________________________________
> > > > > > > > Typo-list mailing list
> > > > > > > > Typo-list at rubyforge.org
> > > > > > > > http://rubyforge.org/mailman/listinfo/typo-list
> > > > > > > >
> > > > > > >
> > > > > > >
> > > > > > > _______________________________________________
> > > > > > > Typo-list mailing list
> > > > > > > Typo-list at rubyforge.org
> > > > > > > http://rubyforge.org/mailman/listinfo/typo-list
> > > > > > >
> > > > > > >
> > > > > > _______________________________________________
> > > > > > Typo-list mailing list
> > > > > > Typo-list at rubyforge.org
> > > > > > http://rubyforge.org/mailman/listinfo/typo-list
> > > > > >
> > > > >
> > > > >
> > > > > _______________________________________________
> > > > > Typo-list mailing list
> > > > > Typo-list at rubyforge.org
> > > > > http://rubyforge.org/mailman/listinfo/typo-list
> > > > >
> > > > >
> > > >
> > > >
> > > > --
> > > > Nikanorov Andrey <nikanorov at gmail.com >
> > > > http://blogru.nikanorov.com
> > > > This email is: [ ] blogable [ x ] ask first [ ] private
> > > > _______________________________________________
> > > > Typo-list mailing list
> > > > Typo-list at rubyforge.org
> > > > http://rubyforge.org/mailman/listinfo/typo-list
> > > >
> > >
> > >
> >
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060616/38453937/attachment-0001.htm 


More information about the Typo-list mailing list