[typo] Typo site errors

phil phil at cryer.us
Wed Jun 7 13:40:09 EDT 2006


So I'm running a site for a friend, but we've had issues for some time.  He hasn't been able to see or edit pages within Admin for months, and all the suggestions I've had never fixed that, but now he can't even have any of his stories come up.  One (that he posted yesterday) works if you click on it, but any older ones bomb with this kind of error when you click to 'read more':

Device not configured
/usr/local/lib/ruby/1.8/logger.rb:513:in `write'
/usr/local/lib/ruby/1.8/logger.rb:513:in `write'
/usr/local/lib/ruby/1.8/monitor.rb:229:in `synchronize'
/usr/local/lib/ruby/1.8/logger.rb:505:in `write'
/usr/local/lib/ruby/1.8/logger.rb:335:in `add'
/usr/local/lib/ruby/1.8/logger.rb:410:in `fatal'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/rescue.rb:42:in `log_error'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/rescue.rb:27:in `rescue_action'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/rescue.rb:108:in `perform_action'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/base.rb:379:in `process_without_filters'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/filters.rb:364:in `process_without_session_management_support'
/usr/local/www/site2/typo/vendor/rails/actionpack/lib/action_controller/session_management.rb:117:in `process'
/usr/local/www/site2/typo/vendor/rails/railties/lib/dispatcher.rb:38:in `dispatch'
/usr/local/www/site2/typo/vendor/rails/railties/lib/webrick_server.rb:115:in `handle_dispatch'
/usr/local/www/site2/typo/vendor/rails/railties/lib/webrick_server.rb:81:in `service'
/usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
/usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
/usr/local/lib/ruby/1.8/webrick/server.rb:173:in `start_thread'
/usr/local/lib/ruby/1.8/webrick/server.rb:162:in `start_thread'
/usr/local/lib/ruby/1.8/webrick/server.rb:95:in `start'
/usr/local/lib/ruby/1.8/webrick/server.rb:92:in `start'
/usr/local/lib/ruby/1.8/webrick/server.rb:23:in `start'
/usr/local/lib/ruby/1.8/webrick/server.rb:82:in `start'
/usr/local/www/site2/typo/vendor/rails/railties/lib/webrick_server.rb:67:in `dispatch'
/usr/local/www/site2/typo/script/server:49

His site is stuck with an older version of Typo, since if we try to update it more things break, and the pages deal in admin doesn't get fixed.  I'm wondering if I could install a fresh 2.60, do a rake migrate to have the database 'unmigrate' back to 2.60 form, and then have it run.  It would still be using the latest Rails and such though, is that going to work?  Is there a 2.60 branch being maintained where I could just get 2.60 w/fixes to get it running on Rails 1.1 for example?

Thanks for the help.

P
-- 
http://fak3r.com - you don't have to kick it



More information about the Typo-list mailing list