[typo] Migration problem - ver # 22

Hal Fulton hal9000 at hypermetrics.com
Thu Jun 1 01:34:32 EDT 2006


Well, I'm taking the plunge.

I updated my typo from trunk for the first time
in months. I updated my gems.

Rails 1.1.2?? All cool between it and Typo?

Anyway, I tried the migration. This is what I got:
(see below).

Any ideas?  Yes, I did back up the db. ;)


Thanks,
Hal


[root at www typo]# rake migrate 2>&1 | tee mig.out
(in /root/typo)
rake aborted!
Multiple migrations have the version number 22

(See full trace by running task with --trace)
[root at www typo]# rake migrate --trace 2>&1 | tee mig.out
(in /root/typo)
** Invoke migrate (first_time)
** Invoke db:migrate (first_time)
** Invoke environment (first_time)
** Execute environment
** Execute db:migrate
rake aborted!
Multiple migrations have the version number 22
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:351:in 
`assert_unique_migration_version'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:342:in 
`migration_classes'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:339:in 
`inject'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:339:in 
`each'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:339:in 
`inject'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:339:in 
`migration_classes'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:327:in 
`migrate'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:294:in `up'
/root/typo/config/../vendor/rails/activerecord/lib/active_record/migration.rb:285:in 
`migrate'
/root/typo/config/../vendor/rails/railties/lib/tasks/databases.rake:4
/root/typo/config/../vendor/rails/railties/lib/tasks/databases.rake:3:in `call'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:387:in `execute'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:357:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:in `invoke_prerequisites'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `send'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in `invoke_prerequisites'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `synchronize'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `each'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
/usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
/usr/local/bin/rake:18:in `load'
/usr/local/bin/rake:18



More information about the Typo-list mailing list