[typo] 855 - can't run with fastcgi

phil phil at cryer.us
Mon Jan 30 13:21:21 EST 2006


I had problems last week after I upgraded some of the ruby* ports on FreeBSD, but I fixed it by (I thought) reinstalling rubygem-actionpack, but alast today I updated some more ruby stuff, and now lighttpd won't start with fastcgi (I'm now running on WEBrick again, so that's a nice backup to have).  I'm concerned that in the error it says "No such file or directory", but I can't find what that's referering to.  I'm sorry if this is outside of the Typo realm, but it's only with Typo that I am working on this stuff.

After the problems I tried reinstalling these ports:

rubygem-actionmailer-1.1.5
rubygem-actionwebservice-1.0.0_1
rubygem-rails-1.0.0
rubygem-activesupport-1.2.5
ruby18-gems-0.8.11
ruby-1.8.4_4,1
rubygem-actionpack-1.11.2_1

Here is the output, not the svn version I'm running and the php -v output showing cgi-fcgi:

[phil at pepe:~/websites/fak3r/typo]$ svn up
At revision 855.

[phil at pepe:~/websites/fak3r/typo]$ ./script/server -e production
=> Booting lighttpd (use 'script/server webrick' to force WEBrick)
=> Rails application started on http://127.0.0.1:3000
=> Call with -d to detach (requires absolute paths in config/lighttpd.conf)
=> Ctrl-C to shutdown server (see config/lighttpd.conf for options)
2006-01-30 11:34:39: (mod_fastcgi.c.989) execve failed for: public/dispatch.fcgi No such file or directory
2006-01-30 11:34:39: (mod_fastcgi.c.1015) the fastcgi-backend public/dispatch.fcgi failed to start:
2006-01-30 11:34:39: (mod_fastcgi.c.1019) child exited with status 2 public/dispatch.fcgi
2006-01-30 11:34:39: (mod_fastcgi.c.1022) if you try do run PHP as FastCGI backend make sure you use the FastCGI enabled version.
You can find out if it is the right one by executing 'php -v' and it should display '(cgi-fcgi)' in the output, NOT (cgi) NOR (cli)
For more information check http://www.lighttpd.net/documentation/fastcgi.html#preparing-php-as-a-fastcgi-program
2006-01-30 11:34:39: (mod_fastcgi.c.1027) If this is PHP on Gentoo add fastcgi to the USE flags
2006-01-30 11:34:39: (mod_fastcgi.c.1314) [ERROR]: spawning fcgi failed.
2006-01-30 11:34:39: (server.c.702) Configuration of plugins failed. Going down.'

[phil at pepe:~/websites/fak3r/typo]$ php -v
PHP 4.4.2 (cgi-fcgi) (built: Jan 26 2006 21:44:10)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with eAccelerator v0.9.4-cvs200601121552-rc1, Copyright (c) 2004-2005 eAccelerator, by eAccelerator
[17709] EACCELERATOR: PHP unclean shutdown
[phil at pepe:~/websites/fak3r/typo]$

Thanks

P
-- 
http://fak3r.com - you don't have to kick it



More information about the Typo-list mailing list