[typo] head/database issues on TxD

Ali Mills alimills at gmail.com
Tue Jan 24 22:18:40 EST 2006


Hey there,

I successfully installed typo's stable release
(http://typo.leetsoft.com/trac/wiki/DownloadStable) on my TextDrive
account, but then I realized that the stable doesn't have tags - only
the head does.  No problem I thought; I'll just re-install.  I
installed the head successfully on my local machine, exported the
database and then went on my way to install on TxD.

I went through all the standard install steps:

1. svn checkout svn://leetsoft.com/typo/trunk

2. created database.yml from database.yml.example

3. created the database based on the exported schema from my local
machine (TxD won't let users run the migrate script on the admin page
because of CPU demand)

4. added conditionals to my lighttpd.config

5. restarted ruby and lighttpd

When I checked my site at my port it was there and working the way
that typo does.  Typo was running!  So, next I created a new account
and logged in, and here's where the trouble started.  On the admin
panel I *cannot* save anything.  On admin's main "Blog Settings" page
when I click "Save my Settings" I'm greeted with "Application error
(Rails)" at the URL "/admin/general/update".  This error isn't
restricted to the "Blog Settings" page.  I also get it when trying to
add a category on the "Categories" page.  From that page I end up
seeing "Application error (Rails)" at the URL "admin/categories/new".

Since I got the head working properly on my local machine and the only
time typo errors seem to happen when writting to or deleting from
database I strongly suspect that I've encountered a database access
issue.  Having that suspicion, I've rebuilt the db several times with
no luck.  Per the Rails book, I also tried to "grant all on
my_database.* to 'myUsername'@'localhost';".  When I tried this, I
received the message, "Access denied for user 'myUsername'@'localhost'
to database 'my_database' ".  My MySQL knowldege is limited, so I
don't know if this message is a big deal or not.

Anyway, are there known issues with running the head on TextDrive?  Do
the issues that I'm encountering sound familiar to anyone?

Thanks a lot.


Ali



More information about the Typo-list mailing list