[typo] Can't log in after (unsuccessful?) database migration

Geir Arne Brevik gab at gab.net
Sat Jan 7 12:24:47 EST 2006


Since Typo is a moving target, I decided yesterday to upgrade my
installation at www.gab.net to the latest version from the SVN trunk.
Since my hoster is Dreamhost, there were of course problems:

* After I uploaded the new files, I went to /admin/ and got the
message I hoped for; everything was OK, and my database supported
* I clicked "migrate database" (or whatever the button says)
* I got Rails Error
* I tried once again, and got the same error
* When I've tried to log in ever since, I got "Login unsuccessful".
Otherwise the installation works like a charm, I can for example add
new comments
* I've looked at my database tables, and they seem updated (compared
to schema.mysql.sql), with the new user notification fields in the
"user" table. My user info also seems unaltered, but no, I can't get
to log in, not by web or MarsEdit.

Has this anything to do with Dreamhost lagging behind with its shared
Rails version? Should I install it myself instead?
But most of all: How can I log in, so I can publish again?

Just a little about where I come from: I'm using my installation of
Typo to learn about RoR, so I may be overlooking obvious things. I'm
not sure wich version I've upgraded from, but I think it was around

Thanks for all your work on Typo (I like it enough to go through all this)! :-)

-Geir Arne

Geir Arne Brevik
gab at gab.net
+47 91 75 64 30

More information about the Typo-list mailing list