[typo] Lost Textile markup after upgrading to the trunk (r865)

Kyle Heon kheon at comcast.net
Fri Feb 24 21:46:50 EST 2006


It would appear that this issue is somehow in the database. I don't have
this behaviour locally after upgrading so I pulled down the MySQL database
and restored it locally, pointed my development environment at it and it is
happening there.
 
Any thoughts as to what I should begin looking for?

Kyle Heon 
kheon at comcast.net 

 

  _____  

From: typo-list-bounces at rubyforge.org
[mailto:typo-list-bounces at rubyforge.org] On Behalf Of Kyle Heon
Sent: Thursday, February 23, 2006 9:32 PM
To: typo-list at rubyforge.org
Subject: Re: [typo] Lost Textile markup after upgrading to the trunk (r865)


Oops, forgot the attachment.

Kyle Heon 
kheon at comcast.net 

 

  _____  

From: typo-list-bounces at rubyforge.org
[mailto:typo-list-bounces at rubyforge.org] On Behalf Of Kyle Heon
Sent: Thursday, February 23, 2006 9:22 PM
To: typo-list at rubyforge.org
Subject: Re: [typo] Lost Textile markup after upgrading to the trunk (r865)


Attached is a copy of a fresh development.log file that includes a single
request to the root of the site.
 
I removed the app and components directories and then re-uploaded them. Next
I did a chmod -R 777 on the folders as I thought it might have something to
do with permissions.
 
Now the list of missing items is smaller, just the initial TextFilterPlugin
lines.

Kyle Heon 
kheon at comcast.net 

 

  _____  

From: typo-list-bounces at rubyforge.org
[mailto:typo-list-bounces at rubyforge.org] On Behalf Of Kyle Heon
Sent: Thursday, February 23, 2006 8:46 PM
To: typo-list at rubyforge.org
Subject: Re: [typo] Lost Textile markup after upgrading to the trunk (r865)


Please forgive me, I'm pretty new to this stuff. I have my site running on
webrick right now and I keep seeing things like this in the logs:
 
TextFilterPlugin: missing default helper path text_filter_plugin_helper
TextFilterPlugin::Markup: missing default helper path
text_filter_plugin/markup_helper
TextFilterPlugin::Macro: missing default helper path
text_filter_plugin/macro_helper
TextFilterPlugin::MacroPre: missing default helper path
text_filter_plugin/macro_pre_helper
TextFilterPlugin::MacroPost: missing default helper path
text_filter_plugin/macro_post_helper
TextFilterPlugin::PostProcess: missing default helper path
text_filter_plugin/post_process_helper
Plugins::Textfilters::AmazonController: missing default helper path
plugins/textfilters/amazon_helper
Plugins::Textfilters::CodeController: missing default helper path
plugins/textfilters/code_helper
Plugins::Textfilters::FlickrController: missing default helper path
plugins/textfilters/flickr_helper
Plugins::Textfilters::HtmlfilterController: missing default helper path
plugins/textfilters/htmlfilter_helper
Plugins::Textfilters::MacroPostController: missing default helper path
plugins/textfilters/macro_post_helper
Plugins::Textfilters::MacroPreController: missing default helper path
plugins/textfilters/macro_pre_helper
Plugins::Textfilters::MarkdownController: missing default helper path
plugins/textfilters/markdown_helper
Plugins::Textfilters::NoneController: missing default helper path
plugins/textfilters/none_helper
Plugins::Textfilters::SmartypantsController: missing default helper path
plugins/textfilters/smartypants_helper
Plugins::Textfilters::SparklineController: missing default helper path
plugins/textfilters/sparkline_helper
Plugins::Textfilters::TextileController: missing default helper path
plugins/textfilters/textile_helper
Plugins::Textfilters::LightboxController: missing default helper path
plugins/textfilters/lightbox_helper
 
I found these in the components folder.

Kyle Heon 
kheon at comcast.net 

 

  _____  

From: scott at lairdmail.com [mailto:scott at lairdmail.com] On Behalf Of Scott
Laird
Sent: Thursday, February 23, 2006 7:44 PM
To: kheon at comcast.net; typo-list at rubyforge.org
Subject: Re: [typo] Lost Textile markup after upgrading to the trunk (r865)


Look in the logs and see if you're getting an exception in the filtering
code; when a filter fails, the input text is passed through unfiltered.


Scott


On 2/23/06, Kyle Heon <kheon at comcast.net> wrote: 

Has anyone else seen this? Any suggestions on what I can do to fix it?

Kyle Heon 
kheon at comcast.net 

 

  _____  

From: typo-list-bounces at rubyforge.org
[mailto:typo-list-bounces at rubyforge.org] On Behalf Of Kyle Heon
Sent: Wednesday, February 22, 2006 9:38 PM
To: typo-list at rubyforge.org
Subject: [typo] Lost Textile markup after upgrading to the trunk (r865)



I upgraded my install of Typo on my site tonight and had more then my fair
share of issues while doing so. I thought I had them all sorted out but now
my Textile markup is being ignored.

I don't know what caused this and really don't know what I can do to fix it.
I've tried re-saving Textile as my markup language

You can see this at www.kyleheon.com. 

Kyle Heon 
kheon at comcast.net 



_______________________________________________
Typo-list mailing list
Typo-list at rubyforge.org
http://rubyforge.org/mailman/listinfo/typo-list




-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060224/d41e7df9/attachment-0001.htm


More information about the Typo-list mailing list