[typo] ActiveRecordStore?

Koen Van der Auwera kvanderauwera at gmail.com
Thu Feb 23 11:00:22 EST 2006


ok, I'll try that.

On 2/23/06, Chris Roos <chris at seagul.co.uk> wrote:
>
> Yes, it's the sessions table.  Sorry I hadn't tested earlier.
>
> I also have a copy of trunk (revision 865) and it works fine.
>
> Complete stab in the dark but how about checking out rails 1.0.0 from
> svn into your vendor/rails directory (to eliminate and problems in your
> gems)?
>
> Chris
>
>
> Koen Van der Auwera wrote:
> > the ActiveRecordStore table that's the table "sessions" right? I got
> > that one.
> >
> > Yes I migrated locally from 2.6 to latest from svn. The migration script
> > ran fine once I commented out the above mentioned line.
> >
> > On 2/23/06, *Chris Roos* <chris at seagul.co.uk
> > <mailto:chris at seagul.co.uk>> wrote:
> >
> >     Sounds like you might be missing the ActiveRecordStore table (at a
> >     guess).  Did you run any new migrations?
> >
> >
> >     Koen Van der Auwera wrote:
> >
> >      > Hi,
> >      >
> >      > I just took the latest typo version from svn and when I try to
> >     start the
> >      > server (script/server) I get the following errormessage:
> >      >
> >      > -----------------------------------------------------------
> >      > => Booting WEBrick...
> >      > c:/ruby/lib/ruby/gems/1.8/gems/activesupport-
> >     1.2.5/lib/active_support/dependencies.rb:200:in
> >      > `const_missing': uninitialized constant ActiveRecordStore
> >      > (NameError)
> >      > from c:/ruby/lib/ruby/gems/1.8/gems/actionpack-
> >      > 1.11.2/lib/action_controller/session_management.rb:23:in
> `const_get'
> >      > from
> >      >
> >     c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2
> /lib/action_controller/session_management.rb:23:in
> >      > `session_store='
> >      > from c:/ruby/lib/ruby/gems/1.8/gems/rails-
> >      > 1.0.0/lib/initializer.rb:256:in `send'
> >      > from
> >      > c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0
> /lib/initializer.rb:256:in
> >      > `initialize_framework_settings'
> >      > from
> >      >
> >     c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:255:in
> >     `each'
> >      > from
> >      > c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0
> /lib/initializer.rb:255:in
> >      > `initialize_framework_settings'
> >      > from
> >      >
> >     c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:252:in
> >     `each'
> >      > from c:/ruby/lib/ruby/gems/1.8/gems/rails-
> >      > 1.0.0/lib/initializer.rb:252:in `initialize_framework_settings'
> >      > ... 12 levels...
> >      > from
> >     c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> >      > `require__'
> >      > from
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> >      > `require'
> >      > from
> >      >
> >     c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5
> /lib/active_support/dependencies.rb:214:in
> >
> >      > `require'
> >      > from script/server:3
> >      > -----------------------------------------------------------
> >      >
> >      > It works ok if I comment out the following line:
> >      > config.action_controller.session_store = :active_record_store
> >      >
> >      > Any idea what I'm missing here?
> >      > (running locally on windows, all gems up to date)
> >      >
> >      > Thanks,
> >      > --
> >      > Koen.
> >      >
> >      >
> >      >
> >
> ------------------------------------------------------------------------
> >
> >      >
> >      > _______________________________________________
> >      > Typo-list mailing list
> >      > Typo-list at rubyforge.org <mailto:Typo-list at rubyforge.org>
> >      > http://rubyforge.org/mailman/listinfo/typo-list
> >
> >     _______________________________________________
> >     Typo-list mailing list
> >     Typo-list at rubyforge.org <mailto:Typo-list at rubyforge.org>
> >     http://rubyforge.org/mailman/listinfo/typo-list
> >
> >
> >
> >
> > --
> > Koen.
> >
> >
> > ------------------------------------------------------------------------
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>



--
Koen.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060223/3abca756/attachment-0001.htm


More information about the Typo-list mailing list