[typo] ActiveRecordStore?

Dominic Mitchell dom at happygiraffe.net
Thu Feb 23 08:42:36 EST 2006


On Thu, Feb 23, 2006 at 02:10:27PM +0100, Koen Van der Auwera wrote:
> Hi,
> 
> I just took the latest typo version from svn and when I try to start the
> server (script/server) I get the following errormessage:
> 
> -----------------------------------------------------------
> => Booting WEBrick...
> c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:200:in
> `const_missing': uninitialized constant ActiveRecordStore
> (NameError)
> from c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/session_management.rb:23:in
> `const_get'
> from c:/ruby/lib/ruby/gems/1.8/gems/actionpack-1.11.2/lib/action_controller/session_management.rb:23:in
> `session_store='
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:256:in
> `send'
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:256:in
> `initialize_framework_settings'
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:255:in
> `each'
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:255:in
> `initialize_framework_settings'
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:252:in
> `each'
> from c:/ruby/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/initializer.rb:252:in
> `initialize_framework_settings'
> ... 12 levels...
> from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require__'
> from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/loadpath_manager.rb:5:in
> `require'
> from c:/ruby/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
> `require'
> from script/server:3
> -----------------------------------------------------------
> 
> It works ok if I comment out the following line:
> config.action_controller.session_store = :active_record_store
> 
> Any idea what I'm missing here?
> (running locally on windows, all gems up to date)

Just a guess, but have you tried running Rails "edge" instead of 1.0.0?

-Dom


More information about the Typo-list mailing list