[typo] Problem with Typo 2.6.0 in subdirectory

Jason Froderman froderman at gmail.com
Mon Feb 20 14:12:45 EST 2006

Hey everybody.  Very new to typo been working with rails some.  Really 
confused with getting typo up and running in production mode.

The website is at (note the subdirectory)

Only a few things show up and it's all broken.  Viewing the source I 
see it's referencing:

It seems to be it's referencing what it should when I run script/server 
-e production...and if I run that command and navigate to, it works beautifully.  It doesn't seem to be showing 
the html/ subdirectory at all...probably because :3000 points at it 

I need it to recognize the subdirectory and I need to better understand 
how typo gets up and running and stays up and running.  If someone 
requests, does it start up the necessary 
processes to work on Apache or not?

I've tried all kinds of .htaccess things...including RewriteBase as 
described here: http://www.typosphere.org/trac/wiki/TypoInSubdirectory

I don't have access to the httpd.conf so I setup the symbolic link and 
use the .htaccess file as described.  Tried just that one line and a 
lot of other stuff.

Per the troubleshooting ideas, I try to run dispatch.fcgi and I get: 
Status: 500 Internal Server Error  It's pointing to ruby properly...I'm 
running Apache/1.3.33 and not finding anything helpful in the logs.

If anyone could help me understand:

#1: How typo gets up and running and stays that way...

#2: Subdirectory problems...

It would mean a ton!


More information about the Typo-list mailing list