[typo] Fastcgi trouble

Francisco Valladolid Hdez. ficovh at yahoo.com
Sat Feb 11 11:58:23 EST 2006


Hi, I recommended using lighttpd with fcgi for Rails.

Regards.

--- Pratik <pratiknaik at gmail.com> wrote:

> Hi Everyone,
> 
> I'm running Apache 1.3.33 - mod_fastcgi/2.4.2 on my
> dedicated server.
> And I've been facing many issues with running typo
> using FastCgi. I'm
> specifying that it should start only one fcgi
> proccess in my
> httpd.conf file. But somehow it's starting multiple
> processes. It
> looks like this is happening because of symbolic
> link. Could Simone
> please suggest solution/workaround ?
> 
> Thanks,
> Pratik.
> 
> root at localhost [/home/typo/typo-2.6.0]# ps -ef |
> grep fcgi
> nobody    4345  2807  0 17:15 ?        00:00:00
> /usr/local/apache/bin/fcgi- -DSSL
> nobody    4346  4345  0 17:15 ?        00:00:01
> /usr/local/bin/ruby
> /home/claes/typo-2.6.0/public/dispatch.fcgi
> nobody    4417  4345 11 17:19 ?        00:00:01
> /usr/local/bin/ruby
> /home/claes/public_html/dispatch.fcgi
> nobody    4420  4345 11 17:19 ?        00:00:01
> /usr/local/bin/ruby
> /home/claes/public_html/dispatch.fcgi
> nobody    4459  4345 16 17:20 ?        00:00:01
> /usr/local/bin/ruby
> /home/claes/public_html/dispatch.fcgi
> 
> root at localhost [/etc/httpd/conf]# grep FastCgiServer
> httpd.conf
> FastCgiServer
> /home/claes/typo-2.6.0/public/dispatch.fcgi
> -idle-timeout 120 -initial-env RAILS_ENV=production
> -processes 1
> 
> --
> http://www.rails.info - Coming Soon !
> 
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
> 


____________________________________
Fco.Valladolid Hdez.
ficovh at yahoo.com

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 


More information about the Typo-list mailing list