[typo] Apache 2 & FastCGI Problems when accessing /admin/

J Cornelius jcornelius at gmail.com
Wed Feb 1 00:49:58 EST 2006


Hello all,

Typo newbie here.

Does anyone know why this error occurs when trying to access the admin
area of Typo?

It outputs the source of public/dispatch.fcgi to the browser.

Running public/dispatch.fcgi from the command line gives this:
(both directly and as '>ruby public/dispatch.fcgi')

[root at www typo]# public/dispatch.fcgi
/usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require__': no such file to load -- fcgi (MissingSourceFile)
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
`require'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
        from /usr/local/lib/ruby/gems/1.8/gems/rails-1.0.0/lib/fcgi_handler.rb:1
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require__'
        from /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from /usr/local/lib/ruby/gems/1.8/gems/activesupport-1.2.5/lib/active_support/dependencies.rb:214:in
`require'
        from public/dispatch.fcgi:22


Any help is appreciated.


--
J Cornelius
~~~~~~~~~~~~
www.jcornelius.com



More information about the Typo-list mailing list