[typo] Migration Issues - Wordpress2

Doug Bromley doug.bromley at gmail.com
Mon Aug 21 14:55:00 EDT 2006


Hi All

I thought I'd managed it a while back - you may remember I had migration issues.
Well I applied the patch from before and tried but it gave an SQL
error in the body so I left it for a couple of weeks to see if it
stabilised and the patches were applied.

I tried again today with gem 4.0.3 of Typo and when I attempt to
migrate my Wordpress2 database I get the following error:

---------------------------------------------------------------------------------------
../../config/../vendor/rails/activerecord/lib/../../activesupport/lib/active_support/dependencies.rb:123:in
`const_missing            ': uninitialized constant TestRequest
(NameError)
        from ../../config/../app/models/blog.rb:178:in `request'
        from ../../config/../app/models/blog.rb:150:in `url_for'
        from ../../config/../app/models/blog.rb:163:in `article_url'
        from ../../config/../app/models/article.rb:26:in `location'
        from ../../config/../app/models/article.rb:45:in `really_send_pings'
        from ../../config/../app/models/content_state/just_published.rb:46:in
`send_pings'
        from ../../config/../app/models/article.rb:72:in `send_pings'
        from ../../config/../app/models/web_notifier.rb:5:in `after_save'
         ... 15 levels...
        from wordpress2.rb:27:in `initialize'
        from wordpress2.rb:285:in `execute_without_timestamps'
        from wordpress2.rb:23:in `initialize'
        from wordpress2.rb:291
---------------------------------------------------------------------------------------

I even attempted an RSS import this time but it didn't seem to import
a thing.  The above error does appear to be similar to the error I
patched on the older version so I tried the same patch but to no avail
- it still fails.

I'd be grateful if anyone could help me out here - I'd love to get
Typo up & running and convert over but I keep hitting brick walls and
its really frustrating.

All the best.

Doug



-- 
Doug Bromley
blog.straw-dogs.co.uk


More information about the Typo-list mailing list