[typo] Line ending problems under Windows?

Brian Hutchison b.hutchison at gmail.com
Mon Aug 21 12:49:59 EDT 2006


No, its multiple files. I cleaned up this one file, ran for a ways and then
hit more problems... opened up the next indicated file & saved, and then hit
another problem, etc. I finally just batch-edited every single file in the
tree and then it was smooth sailing. If you need a list of them that caused
a problem just let me know and I'll install a fresh copy and try again.

Note, it also happened when I installed off the gem in addition to via SVN.
I was playing around with the SVN eol options, but I don't think that's
really it now.  Thank you for your confirmation -- I should have noticed
\003 is not an eol myself but I jumped to conclusions.

Brian

On 8/21/06, Scott Laird <scott at sigkill.org> wrote:
>
> \003 is Control-C, which isn't a Unix line ending character.  Is it
> just this one file?
>
>
> Scott
>
> On 8/19/06, Brian Hutchison <b.hutchison at gmail.com> wrote:
> > Is anyone else having problems with the 4.0.x code (including trunk)
> under
> > Windows? I'm running Windows XP SP2 and I get all sorts of weird errors.
> I
> > believe its related to the line endings.
> >
> > *** example output ***
> >  compile error
> > ./script/../config/../app/views/layouts/accounts.rhtml:3:
> > parse error, unexpected tIDENTIFIER, expecting kEND
> > ./script/../config/../app/views/layouts/accounts.rhtml:4:
> > Invalid char `\003' in expression
> >
> > ./script/../config/../app/views/layouts/accounts.rhtml:4:
> > parse error, unexpected tIDENTIFIER, expecting kEND
> > **************************
> >
> > Each and every time, editing the file in an editor (I typically use
> Textpad
> > & RadRails) solves the problem. In other words, I just open the file add
> a
> > blank line, delete the blank line, then save (this to 'trick' the editor
> > into setting the 'dirty' flag that a save is needed).  This didn't
> happen in
> > the 2.6 code base, but I can't exactly say where things went astray.
> >
> >
> > _______________________________________________
> > Typo-list mailing list
> > Typo-list at rubyforge.org
> > http://rubyforge.org/mailman/listinfo/typo-list
> >
> >
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060821/885a6602/attachment.html 


More information about the Typo-list mailing list