[typo] test failed while attempting to install

Scott Laird scott at sigkill.org
Mon Aug 7 11:50:01 EDT 2006


Yes, the sqlite3-ruby GEM is broken on systems that don't come with
SWIG (http://www.swig.org).  Try installing swig and then
re-installing sqlite3-ruby; that should fix this bug.


Scott

On 8/5/06, Juan Alvarez <alce at mac.com> wrote:
> Hello,
>
> I just downloaded typo gem 4.0 and  installed typo on mac osx 10.4.7
> I receive the following message:
>
>   Cleaning out Typo's cache
> Running tests.  This may take a minute or two
> ***** Tests failed *****
> ** Please run 'rake test' by hand in your install directory.
> ** Report problems to the Typo mailing list.
> ***** Tests failed *****
> Starting Typo on port 4674
>
> I then ran the tests manually and these were the results:
>
> 1) Error:
> test_signup(AccountsControllerTest):
> ActiveRecord::StatementInvalid: TypeError: no implicit conversion
> from nil to integer: PRAGMA table_info(notifications)
> .
> .
> 2) Failure:
> test_create(Admin::ContentControllerTest) [./test/functional/admin/
> content_controller_test.rb:79]:
> <1> expected but was
> <0>.
>
> 3) Error:
> test_request_fires_triggers(Admin::ContentControllerTest):
> NoMethodError: You have a nil object when you didn't expect it!
> The error occured while evaluating nil.publish!
>
> 4) Failure:
> test_new(Admin::PagesControllerTest) [./test/functional/admin/
> pages_controller_test.rb:60]:
> response is not a redirection to all of the options supplied
> (redirection is <{:action=>"show", :id=>0}>), difference: <{:id=>19}>
>
> 5) Error:
> test_blogger_new_post(BackendControllerTest):
> ActiveRecord::RecordNotFound: Couldn't find Article with ID=0
> .
> .
> 6) Error:
> test_blogger_new_post_no_title(BackendControllerTest):
> ActiveRecord::RecordNotFound: Couldn't find Article with ID=0
> .
> .
> 7) Error:
> test_blogger_new_post_with_categories(BackendControllerTest):
> ActiveRecord::RecordNotFound: Couldn't find Article with ID=0
>
> 206 tests, 766 assertions, 2 failures, 7 errors
> rake aborted!
> Test failures
>
> Is there something wrong whith the app or am i doing something wrong?
>
> Thank you
>
>
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
>


More information about the Typo-list mailing list