[typo] uninitialized constant Sidebars::SidebarController

Kyle Heon kheon at comcast.net
Wed Apr 19 18:05:13 EDT 2006


I'm in the process of pushing a new build of my site to TextDrive and after
I'd moved all files and run rake migrate (with success) I fired up lighttpd
w/FCGI. Site loaded but then when I clicked on any link things blew up.

I was able to recreate this locally, via WEBrick in production mode. The
error details are below:

---[production.log]---
ActionView::TemplateError (uninitialized constant
Sidebars::SidebarController) on line #38 of
themes/kyleheon/layouts/default.rhtml:
35: 	<!-- right -->
36: 	<div id="right">
37: 		<%= render :partial => "shared/search" %>
38: 		<%= render_component(:controller => 'sidebars/sidebar',
:action => 'display_plugins') %>
39: 	</div>
40: 
41: 	<!-- center -->

    vendor/rails/activesupport/lib/active_support/dependencies.rb:100:in
`const_missing'
    vendor/rails/activesupport/lib/active_support/inflector.rb:161:in
`module_eval'
    vendor/rails/activesupport/lib/active_support/inflector.rb:161:in
`module_eval'
    vendor/rails/activesupport/lib/active_support/inflector.rb:161:in
`constantize'
 
vendor/rails/activesupport/lib/active_support/core_ext/string/inflections.rb
:59:in `constantize'
    vendor/rails/actionpack/lib/action_controller/components.rb:143:in
`component_class'
    vendor/rails/actionpack/lib/action_controller/components.rb:133:in
`component_response'
    vendor/rails/actionpack/lib/action_controller/components.rb:108:in
`render_component_as_string'
    vendor/rails/actionpack/lib/action_controller/components.rb:107:in
`component_logging_with_unfiltered_options'
    lib/rails_patch/components.rb:10:in `component_logging'
    vendor/rails/actionpack/lib/action_controller/components.rb:107:in
`render_component_as_string'
    vendor/rails/actionpack/lib/action_controller/components.rb:44:in `send'
    vendor/rails/actionpack/lib/action_controller/components.rb:44:in
`render_component'
    #{RAILS_ROOT}/themes/kyleheon/layouts/default.rhtml:38:in
`_run_rhtml__home_kyle_ror_typo_themes_kyleheon_layouts_default'
    vendor/rails/actionpack/lib/action_view/base.rb:314:in `send'
    vendor/rails/actionpack/lib/action_view/base.rb:314:in
`compile_and_render_template'
    vendor/rails/actionpack/lib/action_view/base.rb:290:in `render_template'
    vendor/rails/actionpack/lib/action_view/base.rb:249:in `render_file'
    app/helpers/theme_helper.rb:24:in `render_file'
    app/helpers/theme_helper.rb:17:in `each'
    app/helpers/theme_helper.rb:17:in `render_file'
    vendor/rails/actionpack/lib/action_controller/layout.rb:249:in
`render_without_benchmark'
    vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in
`render'
    vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in
`measure'
    vendor/rails/actionpack/lib/action_controller/benchmarking.rb:53:in
`render'
    app/controllers/articles_controller.rb:63:in `rescue_action_in_public'
    vendor/rails/actionpack/lib/action_controller/rescue.rb:33:in
`rescue_action'
    vendor/rails/actionpack/lib/action_controller/rescue.rb:108:in
`perform_action'
    vendor/rails/actionpack/lib/action_controller/base.rb:381:in `send'
    vendor/rails/actionpack/lib/action_controller/base.rb:381:in
`process_without_filters'
    vendor/rails/actionpack/lib/action_controller/filters.rb:377:in
`process_without_session_management_support'
 
vendor/rails/actionpack/lib/action_controller/session_management.rb:117:in
`process'
    vendor/rails/railties/lib/dispatcher.rb:38:in `dispatch'
    vendor/rails/railties/lib/webrick_server.rb:115:in `handle_dispatch'
    vendor/rails/railties/lib/webrick_server.rb:81:in `service'
    /usr/local/lib/ruby/1.8/webrick/httpserver.rb:104:in `service'
    /usr/local/lib/ruby/1.8/webrick/httpserver.rb:65:in `run'
    /usr/local/lib/ruby/1.8/webrick/server.rb:155:in `start_thread'
    /usr/local/lib/ruby/1.8/webrick/server.rb:144:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:144:in `start_thread'
    /usr/local/lib/ruby/1.8/webrick/server.rb:94:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:89:in `each'
    /usr/local/lib/ruby/1.8/webrick/server.rb:89:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:79:in `start'
    /usr/local/lib/ruby/1.8/webrick/server.rb:79:in `start'
    vendor/rails/railties/lib/webrick_server.rb:67:in `dispatch'
    vendor/rails/railties/lib/commands/servers/webrick.rb:59
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require__'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:18:in
`require'
    vendor/rails/activesupport/lib/active_support/dependencies.rb:147:in
`require'
    vendor/rails/railties/lib/commands/server.rb:30
    script/server:3:in `require'
    script/server:3
---[/production.log]---

I'm not sure what the problem is. I'm running off the Typo trunk (rev 1026)
which has Rails frozen at rev 4231.

Please help.

Kyle Heon
kheon at comcast.net
www.kyleheon.com





More information about the Typo-list mailing list