[typo] Towards 4.0.0

Rodger Donaldson rodgerd at diaspora.gen.nz
Fri Apr 14 08:34:41 EDT 2006


On Fri, Mar 31, 2006 at 04:51:17AM +0100, Piers Cawley wrote:
> Rodger Donaldson <rodgerd at diaspora.gen.nz> writes:
> 
> > On Thu, Mar 30, 2006 at 09:29:48AM +0100, Piers Cawley wrote:
> >> 
> >> Again, I'm interested in everyone's input, but I'm particularly keen
> >> to hear from anyone still running 2.6.0.
> >
> > Last time I tried a rake migrate on my test box it was a disaster
> > area; I'm quite happy to do a dump of my prod 2.6 DB into a dev DB and
> > redo if that will provide useful debugging.
> 
> That would be handy. We're rather more confident of the migration
> routes now that we use BareMigrations. Essentially, all the migrations
> are now protected from changes in our model classes.

Sure.

[rodgerd at sacco typo]$ svn update

[...]

Updated external to revision 4210.

Updated to revision 1021.


[rodgerd at sacco typo]$ rake migrate
(in /home/rodgerd/typo)
rake aborted!
undefined method `namespace' for main:Object
./Rakefile:10

Hmm.  Not so good.

[rodgerd at sacco typo]$ gem list --local

*** LOCAL GEMS ***

[...]

rails (1.0.0)
    Web-application framework with template engine, control-flow layer,
    and ORM.

rake (0.6.2)
    Ruby based make-like utility.

[...]

Hmm.  Is this a problem with sitting on rails-1.0 as opposed to
rails-1.1, the wrong version of rake, or something *really* dumb on my
part?

[rodgerd at sacco typo]$ sudo gem install rails
Attempting local installation of 'rails'
Local gem file not found: rails*.gem
Attempting remote installation of 'rails'
Updating Gem source index for: http://gems.rubyforge.org
Install required dependency rake? [Yn]
Install required dependency activesupport? [Yn]
Install required dependency activerecord? [Yn]
Install required dependency actionpack? [Yn]
Install required dependency actionmailer? [Yn]
Install required dependency actionwebservice? [Yn]
Successfully installed rails-1.1.2
Successfully installed rake-0.7.1
Successfully installed activesupport-1.3.1
Successfully installed activerecord-1.14.2
Successfully installed actionpack-1.12.1
Successfully installed actionmailer-1.2.1
Successfully installed actionwebservice-1.1.2

[rodgerd at sacco typo]$ gem list

*** LOCAL GEMS ***


rails (1.1.2)
    Web-application framework with template engine, control-flow layer,
    and ORM.

rake (0.7.1)
    Ruby based make-like utility.

[rodgerd at sacco typo]$ rake migrate
(in /home/rodgerd/typo)

    Rails does not work with Ruby version 1.8.3.
    Please upgrade to version 1.8.4 or downgrade to 1.8.2.

Ack.  So, I guess the DownloadCurrent page needs to note the
dependency on rails 1.1 and/or rake 0.7.  It's too late to upgrade all
of ruby tonight 8).

-- 
Rodger Donaldson		rodgerd at diaspora.gen.nz
"Not only does the English Language borrow words from other languages, it 
sometimes chases them down dark alleys, hits them over the head, and goes 
through their pockets." -- Eddy Peters 


More information about the Typo-list mailing list