[typo] With trunk, can no longer login as Admin [SOLVED]

Dick Davies rasputnik at gmail.com
Thu Apr 6 17:16:41 EDT 2006


On 06/04/06, phil <phil at cryer.us> wrote:

> > And since I *hate* it when I search mailing lists to find an answer
> > just to see someone say, "never mind, I fixed it"
> > without saying how they fixed it, here ya go:

(google : file under 'possibly not such a great idea' ) :)

> > Symptom: couldn't login as admin to Typo site
> >
> > Solution: go into database, switch to Typo database and enter:
> >
> > delete from users where id=1;
> >
> > fire up your site/admin
> >
> > re-create the admin acct.
> >
> > I'm sure there's other ways to handle this, but this works.  Thanks again

Think that's a bad fix - if you have an auto-increment id field on the users
table, then when you recreate the user he has a different id.
I expect that's why you can't edit any of your old posts.

The best fix is to use the console, find the old user
 me = User.find(1)
in my case, then reset the password with a

  me.password = me.password_confirmation = 'sekrit'
  me.save

(Yes, I forget my password a lot).

> However - the only thing that seems brok3n is when I click on a article title and get to the article page, I don't get the 'Edit' option next to the title to jump right into the edit function even when I'm logged in.  If I go to /admin it'll drop me over there and I can do all of my admin-y stuff, but this functionality was there yesterday before I 'fixed' my login issue.
>
> Is there anything else I need to add to the DB to have my user be 'special'?

--
Rasputin :: Jack of All Trades - Master of Nuns
http://number9.hellooperator.net/



More information about the Typo-list mailing list