[typo] With trunk, can no longer login as Admin [SOLVED]

phil phil at cryer.us
Thu Apr 6 12:57:50 EDT 2006



On Thu, 6 Apr 2006 9:48:40 -0500, phil <phil at cryer.us> wrote:
> 
> 
> On Thu, 06 Apr 2006 09:03:43 -0500, Jake Good <jake at whoisjake.com> wrote:
>> Err copy the hash out of the log/development.log file
>>
>> Minor detail omission.
>>
>> Jake Good wrote:
>>> This might not be the best way... but throw your blog into development
>>> mode... try your OLD password, copy the hash and replace it in the db.
>>>
>>> I didn't that when the hashes went bad after a migrate. Worked like a
>> charm.
>>>
>>> Jake
>>>
>>> Gary Shewan wrote:
>>>
>>>> On 6 Apr 2006, at 13:55, Phil Cryer wrote:
>>>>
>>>>
>>>>> On Wed, 5 Apr 2006 19:32:15 -0400, "Kyle Heon" <kheon at comcast.net>
>>>>> wrote:
>>>>>
>>>>>
>>>>>> I had an issue awhile back with a banged up migration that
>>>>>> prevented me
>>>>>> from
>>>>>> logging into the admin area as well.
>>>>>>
>>>>>> I fixed it by opening up a console and resetting my password. I'm
>>>>>> pretty
>>>>>> sure you need to hash the password first but I believe the
>>>>>> functions you
>>>>>> need are all part of the LoginController.
>>>>>>
>>>>>>
>>>>> Can you tell me how to do this, or is it documented somewhere? (I
>>>>> don't see anything on Typo Trac about it).  Thanks
>>>>>
>>>>>
>>>> You could use phpmyadmin (or whatever you like) to delete your user
>>>> from the user table ... if there aren't any users I'm pretty sure
>>>> Typo let's you sign up with a new user.
> 
> Ah, thanks for everyone's help, this is now fixed.  And since I *hate* it
> when I search mailing lists to find an answer just to see someone say,
> "never mind, I fixed it" without saying how they fixed it, here ya go:
> 
> Symptom: couldn't login as admin to Typo site
> 
> Solution: go into database, switch to Typo database and enter:
> 
> delete from users where id=1;
> 
> fire up your site/admin
> 
> re-create the admin acct.
> 
> I'm sure there's other ways to handle this, but this works.  Thanks again

However - the only thing that seems brok3n is when I click on a article title and get to the article page, I don't get the 'Edit' option next to the title to jump right into the edit function even when I'm logged in.  If I go to /admin it'll drop me over there and I can do all of my admin-y stuff, but this functionality was there yesterday before I 'fixed' my login issue.

Is there anything else I need to add to the DB to have my user be 'special'?

P


> 
> P
> 
> 
>>>>
>>>> Look at /app/controllers/accounts_controller.rb - seems pretty
>>>> straightforward.
>>>> _______________________________________________
>>>> Typo-list mailing list
>>>> Typo-list at rubyforge.org
>>>> http://rubyforge.org/mailman/listinfo/typo-list
>>>>
>>>>
>>>>
>>> _______________________________________________
>>> Typo-list mailing list
>>> Typo-list at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/typo-list
>>>
>>>
>> _______________________________________________
>> Typo-list mailing list
>> Typo-list at rubyforge.org
>> http://rubyforge.org/mailman/listinfo/typo-list
> --
> http://fak3r.com - you dont have to kick it
> 
> _______________________________________________
> Typo-list mailing list
> Typo-list at rubyforge.org
> http://rubyforge.org/mailman/listinfo/typo-list
-- 
http://fak3r.com - you dont have to kick it



More information about the Typo-list mailing list