[typo] Globalize plugin on Typo

Kevin Ballard kevin at sb.org
Thu Apr 6 11:57:40 EDT 2006


Uhh, script/plugin doesn't exist because Typo 2.6.0 is old. You might  
want to try this on trunk instead (or wait for the imminent 4.0  
release).

On Apr 6, 2006, at 1:08 AM, David Verdú wrote:

> Hello! I'm Trying to add localization to my Typo installation with  
> Globalize Plugin but, what my surprise!
>
> 1. script/plugin script doesn't exists. Why Typo hasn't this script?
>
> 2. I have tryed to checkout by hand latest Globalize version into  
> vendor/plugins (plugins folder created by me), vendor and lib  
> folders with subversion. Globalize is taken from http:// 
> svn.globalize-rails.org/svn/globalize/globalize/trunk.
> Then, I invoqued script/generate migrate and rake migrate, and It  
> seems to run well; database was updated with globalize tables. But,  
> when I use on views t method, application breaks with this line:
>
>
> %= link_to("edit".t, { :controller => "admin/content", :action =>  
> "edit", :id => @article },
>          :class => "admintools", :style => "display: none", :id =>  
> "admin_article") %>
>
> Dumping this error:
>
> undefined method `t' for "edit":String
>
>
> Why are typo folders structure slightly different from normal Rails  
> applications? so, What things should I change to set globalize  
> correctly on Typo?
> I'm using typo-2.6.0_rails_1_0

-- 
Kevin Ballard
kevin at sb.org
http://kevin.sb.org
http://www.tildesoft.com


-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2378 bytes
Desc: not available
Url : http://rubyforge.org/pipermail/typo-list/attachments/20060406/86966a47/attachment.bin 


More information about the Typo-list mailing list