[typo] With trunk, can no longer login as Admin

phil phil at cryer.us
Wed Apr 5 16:13:47 EDT 2006


As a followup, I just tried logging in via w.blogger (a client based blog poster) and it failed with 'Invalid login' but I was able to grab this from production.log in Typo:



Processing BackendController#xmlrpc (for 199.249.176.251 at 2006-04-05 15:11:38) [POST]
  Parameters: {"action"=>"xmlrpc", "controller"=>"backend", "methodCall"=>{"methodName"=>"blogger.getUsersBlogs", "params"=>{"param"=>[{"value"=>{"string"=>"E7F0F69AB4125D811D74C797B11A4DC768E9B2BC"}}, {"value"=>{"string"=>"fak3r"}}, {"value"=>{"string"=>"luna16"}}]}}}


RuntimeError (Invalid login):
    /app/apis/typo_web_servicerb:20:in `authenticate'
    /vendor/rails/actionwebservice/lib/action_web_service/invocationrb:163:in `call_interceptors'
    /vendor/rails/actionwebservice/lib/action_web_service/invocationrb:159:in `call_interceptors'
    /vendor/rails/actionwebservice/lib/action_web_service/invocationrb:148:in `before_invocation'
    /vendor/rails/actionwebservice/lib/action_web_service/invocationrb:137:in `perform_invocation'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/abstractrb:43:in `web_service_filtered_invoke'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/abstractrb:38:in `web_service_delegated_invoke'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/abstractrb:57:in `web_service_invoke'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/abstractrb:22:in `invoke_web_service_request'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/action_controller_dispatcherrb:53:in `dispatch_web_service_request'
    /usr/local/lib/ruby/18/benchmarkrb:293:in `measure'
    /vendor/rails/actionwebservice/lib/action_web_service/dispatcher/action_controller_dispatcherrb:51:in `dispatch_web_service_request'
    (eval):1:in `xmlrpc'
    /vendor/rails/actionpack/lib/action_controller/baserb:908:in `perform_action_without_filters'
    /vendor/rails/actionpack/lib/action_controller/filtersrb:355:in `perform_action_without_benchmark'
    /vendor/rails/actionpack/lib/action_controller/benchmarkingrb:69:in `perform_action_without_rescue'
    /usr/local/lib/ruby/18/benchmarkrb:293:in `measure'
    /vendor/rails/actionpack/lib/action_controller/benchmarkingrb:69:in `perform_action_without_rescue'
    /vendor/rails/actionpack/lib/action_controller/rescuerb:82:in `perform_action'
    /vendor/rails/actionpack/lib/action_controller/baserb:379:in `process_without_filters'
    /vendor/rails/actionpack/lib/action_controller/filtersrb:364:in `process_without_session_management_support'
    /vendor/rails/actionpack/lib/action_controller/session_managementrb:117:in `process'
    /vendor/rails/railties/lib/dispatcherrb:38:in `dispatch'
    /vendor/rails/railties/lib/webrick_serverrb:115:in `handle_dispatch'
    /vendor/rails/railties/lib/webrick_serverrb:81:in `service'
    /usr/local/lib/ruby/18/webrick/httpserverrb:104:in `service'
    /usr/local/lib/ruby/18/webrick/httpserverrb:65:in `run'
    /usr/local/lib/ruby/18/webrick/serverrb:173:in `start_thread'
    /usr/local/lib/ruby/18/webrick/serverrb:162:in `start_thread'
    /usr/local/lib/ruby/18/webrick/serverrb:95:in `start'
    /usr/local/lib/ruby/18/webrick/serverrb:92:in `start'
    /usr/local/lib/ruby/18/webrick/serverrb:23:in `start'
    /usr/local/lib/ruby/18/webrick/serverrb:82:in `start'
    /vendor/rails/railties/lib/webrick_serverrb:67:in `dispatch'
    /vendor/rails/railties/lib/commands/servers/webrickrb:59
    /vendor/rails/activesupport/lib/active_support/dependenciesrb:136:in `require'
    /vendor/rails/railties/lib/commands/serverrb:30
    /script/server:3






On Wed, 5 Apr 2006 14:27:12 -0500, Phil Cryer <phil at cryer.us> wrote:
> On Wed, 5 Apr 2006 14:22:47 -0500, "Steve Longdo" <steve.longdo at gmail.com>
> wrote:
>> You might try clearing out the sessions table.  Not sure if that is the
>> problem or not.
>>
>> Trying run: rake purge_sessions_table
>>
>> and see if that clears up your problems :-)
> 
> 
> [phil at pepe:~/websites/fak3r/typo-svn-trunk]$ rake --trace
> purge_sessions_table
> (in /mnt/backup/pepe/home/phil/websites/fak3r/typo-svn-trunk)
> ** Invoke purge_sessions_table (first_time)
> rake aborted!
> Don't know how to build task 'db:sessions:recreate'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1449:in `[]'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:364:in
> `invoke_prerequisites'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:999:in `each'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:363:in
> `invoke_prerequisites'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:356:in `invoke'
> /usr/local/lib/ruby/1.8/thread.rb:135:in `synchronize'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:350:in `invoke'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/lib/rake.rb:1906:in `run'
> /usr/local/lib/ruby/gems/1.8/gems/rake-0.7.1/bin/rake:7
> /usr/local/bin/rake:18
> [phil at pepe:~/websites/fak3r/typo-svn-trunk]$
> 
> 
> 
> 
>>
>> On 4/5/06, Phil Cryer <phil at cryer.us> wrote:
>>>
>>> ** Ok, I did 'gem install rake' and it got me 0.7.1, and now 'rake
>>> migrate' works - thanks.  Sorry if this is an OS question and not a
> Typo
>>> question - but FreeBSD only has 0.6.2 available in ports [
>>> http://www.freshports.org/devel/rubygem-rake/], which is where I
>> installed
>>> it from, what do I mess up if I install it via gem?  Thanks
>>>
>>> Thanks again Steve for the solution Steve.
>>>
>>>
>>> ** I still have the issue of not being able to login on the site - so I
>>> can't admin it, add articles, etc.  log/production.log in Typo (I
> ****'d
>> out
>>> the passwd) shows:
>>>
>>> Processing AccountsController#login (for 199.249.176.251 at 2006-04-05
>>> 13:14:20) [POST]
>>>   Session ID: 89eeda5439f5f7259d464b736e5cf645
>>>   Parameters: {"user_login"=>"fak3r", "action"=>"login",
>>> "controller"=>"accounts", "user_password"=>"******", "login"=>"Login
>> »"}
>>> Rendering  within layouts/accounts
>>> Rendering accounts/login
>>> Completed in 0.01557 (64 reqs/sec) | Rendering: 0.00735 (47%) | DB:
>>> 0.00310 (19%) | 200 OK [http://fak3r.com/accounts/login]
>>>
>>> Meanwhile Apache says:
>>> 199.249.176.251 - - [05/Apr/2006:13:15:59 -0500] "POST /accounts/login
>>> HTTP/1.1" 200 1468 "htt
>>> p://fak3r.com/accounts/login" "Mozilla/5.0 (Windows; U; Windows NT 5.1;
>>> en-US; rv:1.8) Gecko/2
>>> 0060321 Firefox/2.0a1"
>>>
>>> no access errors - or any others found.
>>>
>>> P
>>>
>>>
>>> On Wed, 5 Apr 2006 12:42:14 -0500, "Steve Longdo"
>> <steve.longdo at gmail.com>
>>> wrote:
>>> > You need a newer version of rake 0.70.
>>> >
>>> > On 4/5/06, Phil Cryer <phil at cryer.us> wrote:
>>> >>
>>> >> On Wed, 5 Apr 2006 08:52:02 -0700, Kevin Ballard <kevin at sb.org>
>> wrote:
>>> >> > Can you run `rake --trace migrate`?
>>> >> >
>>> >>
>>> >> Sure, sorry I didn't do that before:
>>> >>
>>> >> [10:59:27] [root at pepe ../fak3r/typo-svn-trunk]# rake --trace migrate
>>> >> (in /mnt/backup/pepe/home/phil/websites/fak3r/typo-svn-trunk)
>>> >> rake aborted!
>>> >> undefined method `namespace' for main:Object
>>> >> ./vendor/rails/railties/lib/tasks/databases.rake:1
>>> >> ./vendor/rails/railties/lib/tasks/rails.rb:4
>>> >> ./vendor/rails/railties/lib/tasks/rails.rb:4
>>> >> /usr/local/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:21:in
>>> >> `require'
>>> >> ./Rakefile:10
>>> >> /usr/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake.rb:1379:in
>>> >> `load_rakefile'
>>> >> /usr/local/lib/ruby/gems/1.8/gems/rake-0.6.2/lib/rake.rb:1448:in
>> `run'
>>> >> /usr/local/lib/ruby/gems/1.8/gems/rake-0.6.2/bin/rake:7
>>> >> /usr/local/bin/rake:18
>>> >> [10:59:33] [root at pepe ../fak3r/typo-svn-trunk]#
>>> >>
>>> >>
>>> >> P
>>> >>
>>> >> > On Apr 5, 2006, at 8:00 AM, phil wrote:
>>> >> >
>>> >> >> [phil at pepe:~/websites/fak3r/typo-svn-trunk]$ rake migrate
>>> >> >> (in /mnt/backup/pepe/home/phil/websites/fak3r/typo-svn-trunk)
>>> >> >> rake aborted!
>>> >> >> undefined method `namespace' for main:Object
>>> >> >> ./Rakefile:10
>>> >> >> [phil at pepe:~/websites/fak3r/typo-svn-trunk]$
>>> >> >
>>> >> >
>>> >>
>>> >> _______________________________________________
>>> >> Typo-list mailing list
>>> >> Typo-list at rubyforge.org
>>> >> http://rubyforge.org/mailman/listinfo/typo-list
>>> >>
>>> >
>>> >
>>>
>>> _______________________________________________
>>> Typo-list mailing list
>>> Typo-list at rubyforge.org
>>> http://rubyforge.org/mailman/listinfo/typo-list
>>
>>
-- 
http://fak3r.com - you dont have to kick it



More information about the Typo-list mailing list