[typo] "Guid has already been taken" error

Cory Vander Jagt cdvander at gmail.com
Mon Apr 3 11:36:17 EDT 2006

It is a mysql database and there are no NULL guids.  Anything else known to
cause this error?  Thanks!

That error tends to happen if you have any guids set to NULL. I don't
> know how people end up with NULL guids, but it's happened in the past
> and caused this error.
> What database is it?

On 31/03/06, Cory Vander Jagt <cdvander at gmail.com> wrote:
> hello -
> sorry for the spam if there is a better place to look for this sort of
> thing, but my old install of typo started acting strangely the other day
> i tried to upgrade.  i wasn't having much luck, so i did a fresh install
> the latest trunk release (977 i believe) and then imported my old articles

> from a text file.
> that worked fine, except now, when i try to post a new article i get the
> following error:
> > 1 error prohibited this article from being saved
> >
> > There were problems with the following fields:
> >
> >     * Guid has already been taken
> >
> I've tried changing and even deleting the old guid's from the database but

> that doesn't help.  any suggestions?
> thanks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20060403/30885a6c/attachment.htm 

More information about the Typo-list mailing list