[typo] admin not working anymore after switching to current

Paul Vanovertveld paul.vanovertveld at gmail.com
Thu Sep 29 04:41:59 EDT 2005


Hello,

I recently converted my wordpress blog into a glamours typo blog. Everything
went fine. But after reading about the stability of the current tree I was
tempted to switch to current from the svn tree.

The update was ok, Everything looked good. I got a page telling me that my
db needed to be updated. That also worked, at least I thought so. Now my
blog is working, but I can't access the admin pages anymore. I am always
redirected to the database update pages. But instead of these pages I am
greeted with

Application Error (Rails)

The production.log shows me these lines when I try to access the admin pages

<snip>
Processing GeneralController#index (for
193.203.227.251<http://193.203.227.251>at Thu Sep 29 10:30:05 CEST
2005)
Parameters: {"action"=>"index", "controller"=>"admin/general"}
Redirected to http://www.pv3.info/admin/general/update_database
Completed in 0.00652 (153 reqs/sec) | DB: 0.00104 (16%) [
http://www.pv3.info/admin]


Processing GeneralController#update_database (for
193.203.227.251<http://193.203.227.251>at Thu Sep 29 10:30:05 CEST
2005)
Parameters: {"action"=>"update_database", "controller"=>"admin/general"}


NoMethodError (undefined method `collect' for nil:NilClass):
app/controllers/admin/general_controller.rb:10:in `update_database'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb:756:in
`send'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb:756:in
`perform_action_without_filters'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/filters.rb:295:in
`perform_action_without_benchmark'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/benchmarking.rb:41:in
`perform_action_without_rescue'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/benchmarking.rb:41:in
`measure'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/benchmarking.rb:41:in
`perform_action_without_rescue'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/rescue.rb:80:in
`perform_action'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb:356:in
`send'
/usr/local/lib/ruby/gems/1.8/gems/actionpack-1.9.1/lib/action_controller/base.rb:356:in
`process'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/dispatcher.rb:32:in
`dispatch'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:144:in
`process_request'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:64:in
`process!'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:55:in
`each_cgi'
/usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in<http://0.8.6.1/./fcgi.rb:597:in>`each'
/usr/local/lib/ruby/gems/1.8/gems/fcgi-0.8.6.1/./fcgi.rb:597:in<http://0.8.6.1/./fcgi.rb:597:in>`each_cgi'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:55:in
`process!'
/usr/local/lib/ruby/gems/1.8/gems/rails-0.13.1/lib/fcgi_handler.rb:21:in
`process!'
/home/lighttpd/vhosts/pv3info/public/dispatch.fcgi:24

</snip>

Any ideas?

regards
Paul
--
-------
Paul Vanovertveld
Vienna, Austria, Europe
www.pv3.info <http://www.pv3.info>
-------
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://rubyforge.org/pipermail/typo-list/attachments/20050929/05908a90/attachment.htm


More information about the Typo-list mailing list